classification
Title: add support string that are not inherited from PyStringObject
Type: behavior Stage: resolved
Components: Versions: Python 2.7
process
Status: closed Resolution: rejected
Dependencies: Superseder:
Assigned To: Nosy List: iritkatriel, yuriy_levchenko
Priority: normal Keywords:

Created on 2016-02-28 13:06 by yuriy_levchenko, last changed 2020-12-31 14:07 by iritkatriel. This issue is now closed.

Messages (3)
msg260974 - (view) Author: yuriy_levchenko (yuriy_levchenko) Date: 2016-02-28 13:06
i have my string object based on COW (https://en.wikibooks.org/wiki/More_C%2B%2B_Idioms/Copy-on-write)

i think i need add flag Py_TPFLAGS_STRING_SUBCLASS

https://bugs.python.org/issue26421

but this only for bases on PyStringObject
msg381915 - (view) Author: Irit Katriel (iritkatriel) * (Python triager) Date: 2020-11-26 21:55
I don't understand what the issue is. Can you clarify?
msg384119 - (view) Author: Irit Katriel (iritkatriel) * (Python triager) Date: 2020-12-31 14:07
If you are still having an issue with this, please create a new ticket and explain better what the problem is. Ideally, attach code that demonstrates the problem (along with what you expected the code to do and what it actually does, and state which system and python version you are seeing the issue on).
History
Date User Action Args
2020-12-31 14:07:25iritkatrielsetstatus: pending -> closed
resolution: rejected
messages: + msg384119

stage: resolved
2020-11-26 21:55:05iritkatrielsetstatus: open -> pending
nosy: + iritkatriel
messages: + msg381915

2016-02-28 13:06:15yuriy_levchenkocreate