classification
Title: Ship python35.lib with the embedded distribution, please
Type: enhancement Stage:
Components: Installation Versions: Python 3.6, Python 3.5
process
Status: closed Resolution: rejected
Dependencies: Superseder:
Assigned To: Nosy List: Thomas Führinger, steve.dower
Priority: normal Keywords:

Created on 2016-02-12 13:27 by Thomas Führinger, last changed 2016-02-13 21:22 by steve.dower. This issue is now closed.

Messages (2)
msg260176 - (view) Author: Thomas Führinger (Thomas Führinger) Date: 2016-02-12 13:27
I would like to use the new embedded distribution and load-time link to python35.dll. It would make things a lot easier if you could also include python35.lib in the file python-3.5.1-embed-win32.zip.
msg260245 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2016-02-13 18:21
It shouldn't make any difference as the lib file is not needed at runtime.

While developing your app, you should use a regular installation to make sure you have all the header files you need. The embeddable distro is for runtime.
History
Date User Action Args
2016-02-13 21:22:49steve.dowersetresolution: not a bug -> rejected
2016-02-13 21:22:34steve.dowersetstatus: open -> closed
resolution: not a bug
2016-02-13 18:21:05steve.dowersetmessages: + msg260245
2016-02-12 23:39:35terry.reedysetnosy: + steve.dower

versions: + Python 3.6
2016-02-12 13:27:33Thomas Führingercreate