classification
Title: Queue().unfinished_tasks not in docs - deliberate?
Type: Stage:
Components: Documentation Versions: Python 3.6, Python 3.4, Python 3.5
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: rhettinger Nosy List: docs@python, frankmillman, rhettinger
Priority: normal Keywords:

Created on 2016-02-05 09:00 by frankmillman, last changed 2016-02-07 09:04 by rhettinger. This issue is now closed.

Messages (2)
msg259645 - (view) Author: Frank Millman (frankmillman) Date: 2016-02-05 09:00
dir(queue.Queue()) shows an attribute 'unfinished_tasks'.

It appears to be the counter referred to in the docs to 'join()', but it is not documented itself.

I would like to make use of it, but I don't know if it is part of the official API for this module.

Please advise.
msg259770 - (view) Author: Raymond Hettinger (rhettinger) * (Python committer) Date: 2016-02-07 09:04
Just as you thought, the 'unfinished_tasks' attribute not intended to be part of the public API for queues.
History
Date User Action Args
2016-02-07 09:04:20rhettingersetstatus: open -> closed
resolution: not a bug
messages: + msg259770
2016-02-07 08:57:41rhettingersetassignee: docs@python -> rhettinger

nosy: + rhettinger
2016-02-05 09:00:58frankmillmancreate