classification
Title: Set PrependPath default to true
Type: enhancement Stage:
Components: Installation, Windows Versions: Python 3.6
process
Status: closed Resolution: rejected
Dependencies: Superseder:
Assigned To: Nosy List: Bruno Salvino, Wallison Resende Santos, paul.moore, steve.dower, terry.reedy, tim.golden, zach.ware
Priority: normal Keywords:

Created on 2016-01-27 16:10 by Wallison Resende Santos, last changed 2016-01-30 03:52 by steve.dower. This issue is now closed.

Messages (4)
msg259028 - (view) Author: Wallison Resende Santos (Wallison Resende Santos) Date: 2016-01-27 16:10
Please, set the PrependPath configuration to true. It's a good option for console developers on windows.
msg259029 - (view) Author: Bruno Salvino (Bruno Salvino) Date: 2016-01-27 16:13
Please, set the PrependPath configuration to true.
msg259231 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2016-01-30 02:18
Are you are referring to the option in the Windows installer to prepend the currently-being-installed Python directory (and the scripts directory) to the system PATH variable?  Is so, making this the default has been proposed and rejected before.  Some developers think it a bad idea. In any case, the current choice is not a bug.
msg259235 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2016-01-30 03:52
Sorry, not happening.

There's a very prominent checkbox on the first page of the installer, which was added under protest.

I'd suggest learning the py.exe launcher instead, which does not suffer from any of the issues that are caused by modifying the global PATH variable.
History
Date User Action Args
2016-01-30 03:52:38steve.dowersetstatus: open -> closed
resolution: rejected
messages: + msg259235
2016-01-30 02:18:07terry.reedysetnosy: + terry.reedy, paul.moore, tim.golden, zach.ware, steve.dower
messages: + msg259231

components: + Windows
type: behavior -> enhancement
2016-01-27 16:13:54Bruno Salvinosetnosy: + Bruno Salvino
messages: + msg259029
2016-01-27 16:10:06Wallison Resende Santoscreate