classification
Title: Error on example using "dialect" parameter. have to be: "dialect=dialect"
Type: enhancement Stage: resolved
Components: Documentation Versions: Python 3.4
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: docs@python Nosy List: SilentGhost, Vasyl Kolomiets, docs@python
Priority: normal Keywords:

Created on 2016-01-14 19:29 by Vasyl Kolomiets, last changed 2016-01-14 19:34 by SilentGhost. This issue is now closed.

Messages (2)
msg258214 - (view) Author: Василь Коломієць (Vasyl Kolomiets) * Date: 2016-01-14 19:29
with open('example.csv') as csvfile:
    dialect = csv.Sniffer().sniff(csvfile.read(1024))
    csvfile.seek(0)
    reader = csv.reader(csvfile, dialect)
    # ... process CSV file contents here ...
--

have to be:
    ...
    reader = csv.reader(csvfile, dialect=dialect)
     # ... process CSV file contents here ...

It's here:
https://docs.python.org/3.4/library/csv.html
msg258215 - (view) Author: SilentGhost (SilentGhost) * (Python triager) Date: 2016-01-14 19:34
No, the shown code works just fine.
History
Date User Action Args
2016-01-14 19:34:16SilentGhostsetstatus: open -> closed

nosy: + SilentGhost
messages: + msg258215

resolution: not a bug
stage: resolved
2016-01-14 19:29:52Vasyl Kolomietscreate