classification
Title: pip install lifetimes - throwing error and unable to install packages
Type: compile error Stage: resolved
Components: Windows Versions: Python 3.5
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: dudestc, eryksun, paul.moore, steve.dower, terry.reedy, tim.golden, zach.ware
Priority: normal Keywords:

Created on 2016-01-04 08:45 by dudestc, last changed 2016-01-08 18:17 by terry.reedy. This issue is now closed.

Files
File name Uploaded Description Edit
log.txt dudestc, 2016-01-04 08:45 log file with messages and error messages
Messages (4)
msg257445 - (view) Author: Debashish Maity (dudestc) Date: 2016-01-04 08:45
Not able to install "lifetimes" package using pip script.
Need urgent help.

Followed the following links for help, but still no success
http://blog.ionelmc.ro/2014/12/21/compiling-python-extensions-on-windows/
http://stackoverflow.com/questions/26473854/python-pip-has-issues-with-path-for-ms-visual-studio-2010-express-for-64-bit-ins/26513378#26513378
msg257492 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2016-01-04 20:53
Since you're on Python 3.5, you'll need Visual Studio 2015 to build extensions.

However, since the extension in question is numpy, you'll need to find prebuilt binaries since you won't be able to compile it yourself just yet. I believe Continuum has builds for 3.5 in Anaconda now.
msg257525 - (view) Author: Eryk Sun (eryksun) * (Python triager) Date: 2016-01-05 08:24
You can build NumPy with only a C compiler, but it won't have accelerated BLAS/LAPACK. However, lifetimes requires SciPy, which in turn requires Fortran. This is a common requirement with a lot of the scientific-computing stack, so you may as well choose a complete solution such as Anaconda.

That said, if you just need a few packages, then Christoph Gohlke provides an extensive collection of wheels [1]. For example, I have a directory with the following wheels downloaded from Christoph's site:

    C:\>dir /b Z:\Python\wheel
    matplotlib-1.5.0-cp35-none-win_amd64.whl
    numpy-1.10.2+mkl-cp35-none-win_amd64.whl
    pandas-0.17.1-cp35-none-win_amd64.whl
    scipy-0.16.1-cp35-none-win_amd64.whl

I'll test installing lifetimes and matplotlib in a virtual environment:

    C:\>py -3 -m venv --symlinks C:\Temp\env35
    C:\>C:\Temp\env35\Scripts\activate.bat

The command-line option "-f directory" makes pip look for packages in a local directory: 

    (env35) C:\>pip install -f Z:\Python\wheel lifetimes matplotlib
    Collecting lifetimes
      Using cached Lifetimes-0.1.6.3.tar.gz
    Collecting matplotlib
    Collecting numpy (from lifetimes)
    Collecting scipy (from lifetimes)
    Collecting pandas>=0.14 (from lifetimes)
    Collecting pyparsing!=2.0.4,>=1.5.6 (from matplotlib)
      Downloading pyparsing-2.0.7-py2.py3-none-any.whl
    Collecting pytz (from matplotlib)
      Using cached pytz-2015.7-py2.py3-none-any.whl
    Collecting python-dateutil (from matplotlib)
      Using cached python_dateutil-2.4.2-py2.py3-none-any.whl
    Collecting cycler (from matplotlib)
      Downloading cycler-0.9.0-py2.py3-none-any.whl
    Collecting six>=1.5 (from python-dateutil->matplotlib)
      Using cached six-1.10.0-py2.py3-none-any.whl
    Installing collected packages: numpy, scipy, six, python-dateutil,
        pytz, pandas, lifetimes, pyparsing, cycler, matplotlib
      Running setup.py install for lifetimes
    Successfully installed cycler-0.9.0 lifetimes-0.1.6.3
        matplotlib-1.5.0 numpy-1.10.2 pandas-0.17.1 pyparsing-2.0.7
        python-dateutil-2.4.2 pytz-2015.7 scipy-0.16.1 six-1.10.0

[1]: http://www.lfd.uci.edu/~gohlke/pythonlibs
msg257772 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2016-01-08 18:17
Debashish: questions on using pip should be directed to python-list, also accessible as newsgroup gmane.comp.python.general at news.gmane.org.  pip is otherwise maintained separately from CPython and has its own bug-reporting system.
History
Date User Action Args
2016-01-08 18:17:54terry.reedysetstatus: open -> closed

nosy: + terry.reedy
messages: + msg257772

resolution: not a bug
stage: resolved
2016-01-05 08:24:49eryksunsetnosy: + eryksun
messages: + msg257525
2016-01-04 20:53:37steve.dowersetmessages: + msg257492
2016-01-04 08:45:06dudestccreate