classification
Title: Weird multiplication
Type: behavior Stage: resolved
Components: IDLE, Windows Versions: Python 3.5
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: LCK, Unit03, paul.moore, steve.dower, tim.golden, zach.ware
Priority: normal Keywords:

Created on 2015-12-29 14:07 by LCK, last changed 2015-12-29 14:59 by LCK. This issue is now closed.

Messages (3)
msg257187 - (view) Author: Alex (LCK) Date: 2015-12-29 14:07
Hi!
I'm nube and just learning, but found weird thing
50000 * 1.1 equals 55000.00000000001, but that's not wright.
I'm using 3.5.1 Shell. My friend checked - his got the same result.
So is it a bug or a feature?
msg257188 - (view) Author: Jacek KoƂodziej (Unit03) * Date: 2015-12-29 14:10
LCK: it's a trait of float point arithmetic in computing: https://docs.python.org/3.5/tutorial/floatingpoint.html . It's not a bug.
msg257192 - (view) Author: Alex (LCK) Date: 2015-12-29 14:59
Wow. Thanks!
History
Date User Action Args
2015-12-29 14:59:17LCKsetmessages: + msg257192
2015-12-29 14:11:43skrahsetstatus: open -> closed
resolution: not a bug
stage: resolved
2015-12-29 14:10:50Unit03setnosy: + Unit03
messages: + msg257188
2015-12-29 14:07:58LCKcreate