classification
Title: Python 3.5.1 and Active Tcl/Tk 8.6.4.1
Type: behavior Stage: resolved
Components: IDLE, macOS, Tkinter Versions: Python 3.5
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: ccgm, gpolo, ned.deily, ronaldoussoren, serhiy.storchaka
Priority: normal Keywords:

Created on 2015-12-17 21:29 by ccgm, last changed 2015-12-17 23:42 by ccgm. This issue is now closed.

Files
File name Uploaded Description Edit
python update 1.png ccgm, 2015-12-17 21:29 screen shot with warning messages
Messages (4)
msg256616 - (view) Author: G (ccgm) Date: 2015-12-17 21:29
I have installed one copy of Python 3.5.1 and Tcl/Tk 8.6.4.1 in a high school lab with 28 more computers. Want to be sure I'm doing it correctly. Before the update we were running Python 2.7.10 and always got a warning: Tcl/Tk (8.5.9) may be unstable. I'm still getting the same warning after installing Tcl/Tk 8.6.4.1 . What to I need to do so 3.5.1 sees the correct Tcl/Tk file? What does unstable in this context mean? We had no issues I was aware of.
msg256617 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2015-12-17 22:12
Please read the information at the web page linked to in that message you have been seeing:  https://www.python.org/download/mac/tcltk/.  As explained there, the current Pythons downloaded from python.org for OS X dynamically link with Tcl/Tk 8.5.x, not 8.6.x.  You should download and install the latest ActiveTcl 8.5 version for OS X which is currently 8.5.18.0 from http://www.activestate.com/activetcl/downloads.  You don't need to uninstall the 8.6.5.1 version that you've already installed; it will be ignored.
msg256629 - (view) Author: G (ccgm) Date: 2015-12-17 23:42
Thank you very much. 

Sent from George Moreno's iPhone

> On Dec 17, 2015, at 15:12, Ned Deily <report@bugs.python.org> wrote:
> 
> 
> Ned Deily added the comment:
> 
> Please read the information at the web page linked to in that message you have been seeing:  https://www.python.org/download/mac/tcltk/.  As explained there, the current Pythons downloaded from python.org for OS X dynamically link with Tcl/Tk 8.5.x, not 8.6.x.  You should download and install the latest ActiveTcl 8.5 version for OS X which is currently 8.5.18.0 from http://www.activestate.com/activetcl/downloads. You don't need to uninstall the 8.6.5.1 version that you've already installed; it will be ignored.
> 
> ----------
> resolution:  -> not a bug
> stage:  -> resolved
> status: open -> closed
> 
> _______________________________________
> Python tracker <report@bugs.python.org>
> <http://bugs.python.org/issue25897>
> _______________________________________
msg256630 - (view) Author: G (ccgm) Date: 2015-12-17 23:42
Thank you very much

Sent from George Moreno's iPhone

> On Dec 17, 2015, at 14:48, SilentGhost <report@bugs.python.org> wrote:
> 
> 
> Changes by SilentGhost <ghost.adh@gmail.com>:
> 
> 
> ----------
> components: +IDLE, Macintosh, Tkinter
> nosy: +gpolo, ned.deily, ronaldoussoren, serhiy.storchaka
> 
> _______________________________________
> Python tracker <report@bugs.python.org>
> <http://bugs.python.org/issue25897>
> _______________________________________
History
Date User Action Args
2015-12-17 23:42:03ccgmsetmessages: + msg256630
2015-12-17 23:42:03ccgmsetmessages: + msg256629
2015-12-17 22:12:14ned.deilysetstatus: open -> closed
resolution: not a bug
messages: + msg256617

stage: resolved
2015-12-17 21:48:23SilentGhostsetnosy: + gpolo, serhiy.storchaka, ronaldoussoren, ned.deily
components: + IDLE, macOS, Tkinter
2015-12-17 21:29:54ccgmcreate