classification
Title: Reference leaks in test_smtplib
Type: resource usage Stage: resolved
Components: Tests Versions: Python 3.6
process
Status: closed Resolution: out of date
Dependencies: Superseder:
Assigned To: Nosy List: SilentGhost, ZackerySpytz, corona10, serhiy.storchaka, shihai1991
Priority: normal Keywords:

Created on 2015-11-27 21:41 by serhiy.storchaka, last changed 2020-02-12 14:09 by corona10. This issue is now closed.

Messages (6)
msg255491 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2015-11-27 21:41
$ ./python -m test.regrtest -uall -R 3:3 test_smtplib
[1/1] test_smtplib
beginning 6 repetitions
123456
......
test_smtplib leaked [0, 1, 1] references, sum=2
test_smtplib leaked [0, 1, 2] memory blocks, sum=3
1 test failed:
    test_smtplib
msg258213 - (view) Author: SilentGhost (SilentGhost) * (Python triager) Date: 2016-01-14 19:26
Serhiy, I cannot reproduce these leaks on recent checkout. Is this something that's still happens for you?
msg258224 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2016-01-14 21:22
The result of searching leaks is not stable. I ran the test 10 times and got failures 3 times.
msg351762 - (view) Author: Zackery Spytz (ZackerySpytz) * (Python triager) Date: 2019-09-11 05:21
I cannot reproduce these leaks. I think this issue should be closed.
msg361620 - (view) Author: hai shi (shihai1991) * Date: 2020-02-08 03:38
> I cannot reproduce these leaks. I think this issue should be closed.

+1, I have run 15+ times in my vm but not found these leaks:(
msg361895 - (view) Author: Dong-hee Na (corona10) * (Python triager) Date: 2020-02-12 14:09
+1 for me to close this issue.
On the master branch, this issue is not reproducible.
I am closing this issue, if someone wants to open this issue, please re-open this :)
History
Date User Action Args
2020-02-12 14:09:28corona10setstatus: open -> closed

nosy: + corona10
messages: + msg361895

resolution: out of date
stage: resolved
2020-02-08 03:38:45shihai1991setnosy: + shihai1991
messages: + msg361620
2019-09-11 05:21:06ZackerySpytzsetnosy: + ZackerySpytz
messages: + msg351762
2016-01-14 21:22:10serhiy.storchakasetmessages: + msg258224
2016-01-14 19:26:17SilentGhostsetnosy: + SilentGhost
messages: + msg258213
2015-11-27 21:41:04serhiy.storchakacreate