Title: Add PAYLOAD_TOO_LARGE / URI_TOO_LONG (new name in RFC 7231)
Type: enhancement Stage: patch review
Components: Library (Lib) Versions: Python 3.6
Status: open Resolution:
Dependencies: Superseder:
Assigned To: Nosy List: martin.panter, spaceone
Priority: normal Keywords:

Created on 2015-11-27 00:30 by spaceone, last changed 2015-11-27 01:54 by martin.panter.

Messages (3)
msg255444 - (view) Author: SpaceOne (spaceone) Date: 2015-11-27 00:30
Add PAYLOAD_TOO_LARGE status code to http package.
msg255446 - (view) Author: SpaceOne (spaceone) Date: 2015-11-27 00:38
Also URI_TOO_LONG has been changed.
msg255447 - (view) Author: Martin Panter (martin.panter) * (Python committer) Date: 2015-11-27 01:54
In general, I’m not sure it is worth adding aliases for various names used in different RFCs. But you could argue that this is appropriate because the old names are unnecessarily long. Another example would be HTTPStatus.REQUESTED_RANGE_NOT_SATISFIABLE vs “Range Not Satisfiable” <>.

If we were to go ahead with this, it would need a documentation update. A test case would also be nice, ensuring that the new name is the “one true” name, and the old name is an alias.
Date User Action Args
2015-11-27 01:54:54martin.pantersetversions: + Python 3.6
nosy: + martin.panter

messages: + msg255447

type: enhancement
stage: patch review
2015-11-27 00:38:56spaceonesetmessages: + msg255446
title: Add PAYLOAD_TOO_LARGE (new name in RFC 7231) -> Add PAYLOAD_TOO_LARGE / URI_TOO_LONG (new name in RFC 7231)
2015-11-27 00:30:04spaceonecreate