classification
Title: changing sys.dont_write_bytecode has not effect
Type: Stage:
Components: Documentation, Interpreter Core Versions: Python 2.6
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: georg.brandl Nosy List: benjamin.peterson, georg.brandl
Priority: high Keywords:

Created on 2008-04-05 14:43 by benjamin.peterson, last changed 2008-04-05 17:00 by benjamin.peterson. This issue is now closed.

Messages (2)
msg64976 - (view) Author: Benjamin Peterson (benjamin.peterson) * (Python committer) Date: 2008-04-05 14:43
According to the 2.6 docs, says you can set it yourself to control
bytecode generation. That doesn't work because the dont_write_bytecode
flag is set from command option and never looked at again. Either we
should remove this misleading information or use PySys_GetObject in
pythonrun.c where the flag is used.
msg64988 - (view) Author: Georg Brandl (georg.brandl) * (Python committer) Date: 2008-04-05 16:52
Sorry, I can't see what's wrong here. See import.c which indeed uses
PySys_GetObject to retrieve the value of dont_write_bytecode.
History
Date User Action Args
2008-04-05 17:00:03benjamin.petersonsetstatus: open -> closed
resolution: not a bug
2008-04-05 16:52:29georg.brandlsetmessages: + msg64988
2008-04-05 14:43:08benjamin.petersoncreate