classification
Title: use argparse for the calendar module
Type: Stage: resolved
Components: Library (Lib) Versions: Python 3.6
process
Status: closed Resolution: duplicate
Dependencies: Superseder: Use argparse in the calendar module
View: 18973
Assigned To: Nosy List: matrixise, serhiy.storchaka
Priority: normal Keywords: patch

Created on 2015-10-28 19:39 by matrixise, last changed 2015-10-28 20:25 by serhiy.storchaka. This issue is now closed.

Files
File name Uploaded Description Edit
calendar_move_to_argparse.patch matrixise, 2015-10-28 19:39 review
Messages (4)
msg253619 - (view) Author: Stéphane Wirtel (matrixise) * (Python committer) Date: 2015-10-28 19:39
optparse is marked as deprecated. 

I have moved argparse for the calendar module.

Need reviews.
msg253622 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2015-10-28 19:52
This is a duplicate of issue18973.
msg253623 - (view) Author: Stéphane Wirtel (matrixise) * (Python committer) Date: 2015-10-28 19:57
Why do you close it ? Ok, it's a duplicated issue, but the other issue is not closed. So, in that issue, there is no tests, maybe we can add some tests and re-submit a new patch.

What do you think?
msg253626 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2015-10-28 20:25
Because we need only one issue for every feature.

Tests was committed in issue18982. The patch in issue18973 just waits for review.
History
Date User Action Args
2015-10-28 20:25:30serhiy.storchakasetmessages: + msg253626
2015-10-28 19:57:47matrixisesetmessages: + msg253623
2015-10-28 19:52:14serhiy.storchakasetstatus: open -> closed

superseder: Use argparse in the calendar module

nosy: + serhiy.storchaka
messages: + msg253622
resolution: duplicate
stage: resolved
2015-10-28 19:39:01matrixisecreate