classification
Title: shutil: NameError (WindowsError) when moving from ext3 to fat32 under linux
Type: crash Stage:
Components: Library (Lib) Versions: Python 2.5
process
Status: closed Resolution: duplicate
Dependencies: Superseder:
Assigned To: trent Nosy List: draghuram, jerome.chabod, trent
Priority: normal Keywords: easy

Created on 2008-04-04 14:43 by jerome.chabod, last changed 2008-06-23 15:23 by draghuram. This issue is now closed.

Messages (3)
msg64930 - (view) Author: Chabod (jerome.chabod) Date: 2008-04-04 14:43
shutil generate a NameError (WindowsError) exception when moving a
directory from an ext3 to a fat32 under linux

To reproduce it: 
under linux, current path on an ext3 filesytem, try to enter following
commands: 
mkdir toto #on an ext3 partition
python
import shutil
shutil.move("toto", "/media/fat32/toto") # /media/fat32 is mounted on a
fat32 filesystem

You will produce following error:
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/lib/python2.5/shutil.py", line 196, in move
    copytree(src, dst, symlinks=True)
  File "/usr/lib/python2.5/shutil.py", line 132, in copytree
    except WindowsError:
NameError: global name 'WindowsError' is not defined

Tested on ubuntu Feisty and a newly installed Hardy-beta.
msg64931 - (view) Author: Raghuram Devarakonda (draghuram) (Python triager) Date: 2008-04-04 14:53
This problem has been noticed as part of issue1545 and a patch with the
fix has been proposed but has a small problem with it. Do you want to
take a look?
msg68636 - (view) Author: Raghuram Devarakonda (draghuram) (Python triager) Date: 2008-06-23 15:23
This is duplicate of 3134. I posted a patch there.
History
Date User Action Args
2008-06-23 15:23:14draghuramsetstatus: open -> closed
resolution: duplicate
messages: + msg68636
2008-04-04 14:53:19draghuramsetnosy: + draghuram
messages: + msg64931
2008-04-04 14:50:56trentsetkeywords: + easy
assignee: trent
nosy: + trent
2008-04-04 14:47:27jerome.chabodsettitle: shutil: NameError (WindowsWrror) when moving from ext3 to fat32 under linux -> shutil: NameError (WindowsError) when moving from ext3 to fat32 under linux
2008-04-04 14:43:17jerome.chabodcreate