classification
Title: Idle: debugger source line highlighting fails again
Type: behavior Stage: resolved
Components: IDLE Versions: Python 3.6, Python 3.4, Python 3.5, Python 2.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: markroseman, terry.reedy
Priority: normal Keywords:

Created on 2015-09-28 03:16 by terry.reedy, last changed 2015-10-12 16:45 by markroseman. This issue is now closed.

Messages (4)
msg251746 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2015-09-28 03:16
Re-occurrence of #14146. On that issue, msg225380, 2014-08-15, I said "Debugger source line highlighting works fine." I am really sure it was true when I posted previously, 2013-05-29.  In 3.4.3, Feb 24 2015, it is not working.  Ditto for 2.7.10 and 3.5.0, released subsequently, and repository versions of 2.7 and 3.4,  The problem is not the fix in #14146, which I tested separately before replacing it in #24972.
msg251982 - (view) Author: Mark Roseman (markroseman) * Date: 2015-10-01 00:29
Was the 'source' checkbox in the debugger checked?
msg252834 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2015-10-12 02:01
No.  Turning it on, I discovered why off is default. When it on, it sometimes does surprising things on IDLE.  For instance, print('x') is (usually) a builtin and can not be stepped into.  However, it calls sys.stdout.write('x'+'\n').  Under Idle, user process sys.stdout is PyShell.Pseudofile, so when source is checked, 'step' on a line with print opens the file and highlights lines in the write method.

Step should ask before opening a file, and/or a 'smart step' is needed.
msg252872 - (view) Author: Mark Roseman (markroseman) * Date: 2015-10-12 16:45
FYI, the new debugger UI has an option to only show highlights in already open files (i.e. don't open new ones)
History
Date User Action Args
2015-10-12 16:45:10markrosemansetmessages: + msg252872
2015-10-12 02:01:21terry.reedysetstatus: open -> closed
resolution: not a bug
messages: + msg252834

stage: test needed -> resolved
2015-10-01 00:29:42markrosemansetmessages: + msg251982
2015-09-28 03:16:01terry.reedycreate