classification
Title: Tkinter modules built successfully but removed because they could not be imported
Type: compile error Stage: resolved
Components: Tkinter Versions: Python 3.5
process
Status: closed Resolution: duplicate
Dependencies: Superseder: Compilation Error with Python 3.6.1/3.6.3 with Tkinter
View: 31817
Assigned To: Nosy List: abrantesasf, ned.deily, serhiy.storchaka
Priority: normal Keywords:

Created on 2015-09-27 14:09 by abrantesasf, last changed 2020-05-29 10:26 by ned.deily. This issue is now closed.

Messages (5)
msg251703 - (view) Author: Abrantes Araujo Silva Filho (abrantesasf) Date: 2015-09-27 14:09
I'm trying to compile Python 3.5 on a CentOS 7.1, with TCL 8.6.4, but make always give me the following message:

*** WARNING: renaming "_tkinter" since importing it failed: build/lib.linux-x86_64-3.5/_tkinter.cpython-35m-x86_64-linux-gnu.so: undefined symbol: Tcl_GetCharLength

Following modules built successfully but were removed because they could not be imported:
_tkinter


The configure command was the following (both, Tcl and Tk are installed under /usr/local/lib/tcl8.6.4):

CXX=g++ ./configure --prefix=/usr/local/python3 --enable-shared --enable-loadable-sqlite-extensions --enable-ipv6 --with-tcltk-includes="-I/usr/local/lib/tcl8.6.4/include" --with-tcltk-libs="-L/usr/local/lib/tcl8.6.4/lib"

I could not found a solution for this issue, and I do not know if this is a bug.
msg251704 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2015-09-27 14:24
Do you have other Tcl versions in 8.6 branch installed? Try to set

export LD_LIBRARY_PATH=/usr/local/lib/tcl8.6.4/lib
msg251728 - (view) Author: Abrantes Araujo Silva Filho (abrantesasf) Date: 2015-09-27 21:52
No, I do not have any other Tcl version on my system, and my LD_LIBRARY_PATH alredy points to Tcl directory.

The problem with tkinter persist even if I explicity export LD_LIBRARY_PATH before the compilation.

Any other ideas?

Thanks!
msg251791 - (view) Author: Abrantes Araujo Silva Filho (abrantesasf) Date: 2015-09-28 19:26
I tried with LD_RUN_PATH, but the same compile error still there.
msg370292 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2020-05-29 10:26
It looks like this is the same issue that has been discussed in later Issue31817. Since there has been more discussion there, let's close this as a duplicate of that one.
History
Date User Action Args
2020-05-29 10:26:45ned.deilysetstatus: open -> closed

superseder: Compilation Error with Python 3.6.1/3.6.3 with Tkinter

nosy: + ned.deily
messages: + msg370292
resolution: duplicate
stage: resolved
2015-09-28 19:26:04abrantesasfsetmessages: + msg251791
2015-09-27 21:52:06abrantesasfsetmessages: + msg251728
2015-09-27 14:24:28serhiy.storchakasetnosy: + serhiy.storchaka
messages: + msg251704
2015-09-27 14:09:15abrantesasfcreate