classification
Title: AssertionError from asyncio Queue get
Type: behavior Stage: resolved
Components: asyncio Versions: Python 3.5
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: gvanrossum Nosy List: gvanrossum, python-dev, vstinner, yselivanov
Priority: release blocker Keywords: 3.5regression

Created on 2015-09-25 17:27 by gvanrossum, last changed 2015-09-29 04:03 by gvanrossum. This issue is now closed.

Messages (6)
msg251590 - (view) Author: Guido van Rossum (gvanrossum) * (Python committer) Date: 2015-09-25 17:27
See https://github.com/python/asyncio/issues/265 and https://github.com/python/asyncio/issues/268. This looks like an important regression and we should fix it before 3.5.1 goes out.

The symptom is "AssertionError: queue non-empty, why are getters waiting?" from Queue.get or Queue.get_nowait. The first issue discusses the cause and a possible hack to fix it.
msg251591 - (view) Author: Yury Selivanov (yselivanov) * (Python committer) Date: 2015-09-25 18:12
> This looks like an important regression and we should fix it before 3.5.1 goes out.

I agree.  Any ETA on 3.5.1?
msg251604 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2015-09-25 20:10
2015-09-25 20:12 GMT+02:00 Yury Selivanov <report@bugs.python.org>:
>> This looks like an important regression and we should fix it before 3.5.1 goes out.
>
> I agree.  Any ETA on 3.5.1?

See https://mail.python.org/pipermail/python-dev/2015-September/141705.html
msg251649 - (view) Author: Guido van Rossum (gvanrossum) * (Python committer) Date: 2015-09-26 15:10
I have a fix pending here: https://github.com/python/asyncio/pull/269
msg251770 - (view) Author: Roundup Robot (python-dev) (Python triager) Date: 2015-09-28 14:46
New changeset 1ea306202d5d by Guido van Rossum in branch '3.4':
Issue #25233: Rewrite the guts of Queue to be more understandable and correct.
https://hg.python.org/cpython/rev/1ea306202d5d

New changeset a48d90049ae2 by Guido van Rossum in branch '3.5':
Issue #25233: Rewrite the guts of Queue to be more understandable and correct. (Merge 3.4->3.5.)
https://hg.python.org/cpython/rev/a48d90049ae2
msg251798 - (view) Author: Roundup Robot (python-dev) (Python triager) Date: 2015-09-28 20:36
New changeset 58695845e159 by Guido van Rossum in branch 'default':
Issue #25233: Rewrite the guts of Queue to be more understandable and correct. (Merge 3.5->default.)
https://hg.python.org/cpython/rev/58695845e159
History
Date User Action Args
2015-09-29 04:03:36gvanrossumsetstatus: open -> closed
assignee: gvanrossum
resolution: fixed
stage: resolved
2015-09-28 20:36:06python-devsetmessages: + msg251798
2015-09-28 14:46:34python-devsetnosy: + python-dev
messages: + msg251770
2015-09-26 15:10:29gvanrossumsetmessages: + msg251649
2015-09-25 20:10:40vstinnersetmessages: + msg251604
2015-09-25 18:12:02yselivanovsetmessages: + msg251591
2015-09-25 17:27:20gvanrossumcreate