This issue tracker has been migrated to GitHub, and is currently read-only.
For more information, see the GitHub FAQs in the Python's Developer Guide.

classification
Title: Windows installation does not appear in list of installed applications
Type: behavior Stage:
Components: Installation, Windows Versions: Python 3.5
process
Status: closed Resolution: duplicate
Dependencies: Superseder: Windows All Users installation places uninstaller in user profile
View: 25166
Assigned To: Nosy List: chrullrich, paul.moore, steve.dower, tim.golden, zach.ware
Priority: normal Keywords:

Created on 2015-09-18 08:06 by chrullrich, last changed 2022-04-11 14:58 by admin. This issue is now closed.

Messages (2)
msg250954 - (view) Author: Christian Ullrich (chrullrich) * Date: 2015-09-18 08:06
The new Windows installer always places the uninstallation registry key into HKCU of the executing user. This is correct for a per-user installation, but when run with InstallAllUsers=1, the key should go into HKLM instead.

The "Programs and Features" list of installed applications is assembled from the HKLM and HKCU keys. In many cases, a system-wide installation will be performed by temporarily elevating the installer to a user account with administrator privileges on the local system. However, since Vista, the "Programs and Features" list is always run in the logged-on user's Explorer process, even when started by a different user (such as in an elevated command prompt). With the uninstallation key going into HKCU of some administrative account, the Python installation will not appear in this list, hence, cannot easily be removed.

Ceterum censeo: This bug would have been avoided by using MSI as the distribution package format.
msg251379 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2015-09-23 01:08
This is caused by the same configuration as issue 25166, so I'm closing this one as a duplicate.
History
Date User Action Args
2022-04-11 14:58:21adminsetgithub: 69349
2015-09-23 01:08:15steve.dowersetstatus: open -> closed
superseder: Windows All Users installation places uninstaller in user profile
resolution: duplicate
messages: + msg251379
2015-09-18 08:06:21chrullrichcreate