classification
Title: platform.platform() incorrectly identifies Windows 10 as 'Windows-8-6.2.9200'
Type: behavior Stage: resolved
Components: Library (Lib), Windows Versions: Python 3.4, Python 2.7
process
Status: closed Resolution: duplicate
Dependencies: Superseder: Finding the Windows version getting messier (detect windows 8.1?)
View: 19143
Assigned To: Nosy List: Andrey Fedyashov, lemburg, paul.moore, serhiy.storchaka, steve.dower, tim.golden, zach.ware
Priority: normal Keywords:

Created on 2015-09-16 10:59 by Andrey Fedyashov, last changed 2015-09-16 15:37 by zach.ware. This issue is now closed.

Messages (3)
msg250837 - (view) Author: Andrey Fedyashov (Andrey Fedyashov) Date: 2015-09-16 10:59
Here's actual OS version:
OS Name:                   Microsoft Windows 10 Enterprise Insider Preview
OS Version:                10.0.10534 N/A Build 10534
OS Manufacturer:           Microsoft Corporation
OS Configuration:          Standalone Workstation
OS Build Type:             Multiprocessor Free

Here is bug repro with Python 3.4

Python 3.4.3 (v3.4.3:9b73f1c3e601, Feb 24 2015, 22:44:40) [MSC v.1600 64 bit (AMD64)] on win32
Type "help", "copyright", "credits" or "license" for more information.
>>> import platform
>>> platform.platform()
'Windows-8-6.2.9200'

Here is bug repro with Python 2.7

Python 2.7.10 (default, May 23 2015, 09:44:00) [MSC v.1500 64 bit (AMD64)] on win32
Type "help", "copyright", "credits" or "license" for more information.
>>> import platform
>>> platform.platform()
'Windows-8-6.2.9200'
msg250839 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2015-09-16 11:22
A duplicate of issue19143?
msg250840 - (view) Author: Marc-Andre Lemburg (lemburg) * (Python committer) Date: 2015-09-16 11:46
On 16.09.2015 13:22, Serhiy Storchaka wrote:
> 
> A duplicate of issue19143?

I guess so.
History
Date User Action Args
2015-09-16 15:37:02zach.waresetstage: resolved
2015-09-16 15:36:45zach.waresetsuperseder: Finding the Windows version getting messier (detect windows 8.1?)
2015-09-16 11:46:20lemburgsetstatus: open -> closed
resolution: duplicate
2015-09-16 11:46:03lemburgsetmessages: + msg250840
2015-09-16 11:22:11serhiy.storchakasetnosy: + lemburg, serhiy.storchaka
messages: + msg250839
2015-09-16 10:59:18Andrey Fedyashovcreate