classification
Title: Non-web installer fails without a connection when doing debug install
Type: behavior Stage: resolved
Components: Installation, Windows Versions: Python 3.5
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: steve.dower Nosy List: paul.moore, python-dev, steve.dower, thijsvandien, tim.golden, zach.ware
Priority: normal Keywords:

Created on 2015-09-15 12:28 by thijsvandien, last changed 2015-09-23 01:25 by steve.dower. This issue is now closed.

Files
File name Uploaded Description Edit
Python 3.5.0 (32-bit)_20150915141555.log thijsvandien, 2015-09-15 12:33
Messages (4)
msg250763 - (view) Author: Thijs van Dien (thijsvandien) Date: 2015-09-15 12:28
Python 3.5.0 offers a web installer. This implies that the other installer works offline. This is the case for the default component selection. When debug symbols/binaries are selected, the setup fails with error code 0x80070642 saying the user aborted the installation. This is a severe usability issue. Either everything should be included, or, if that makes the installer too big, "Install debugging symbols" should be "Download and install debugging symbols" - likewise "Install debug binaries" should be "Download and install debug binaries." When downloading fails, the failure message should mention that, rather than blaming the user for something they haven't done.

Tested under Windows 7 SP1 X86 with the X86 non-web installer of Python 3.5.0.
msg250764 - (view) Author: Thijs van Dien (thijsvandien) Date: 2015-09-15 12:33
Although I think the issue is pretty clear, I'm attaching the log file for completion's sake.
msg251357 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2015-09-22 22:19
Yeah, changing the item description is a good suggestion.

It basically doubles the size of the download to include everything all at once.
msg251363 - (view) Author: Roundup Robot (python-dev) (Python triager) Date: 2015-09-23 00:01
New changeset 4e98c622ab20 by Steve Dower in branch '3.5':
Issue #25126: Clarifies that the non-web installer will download some components.
https://hg.python.org/cpython/rev/4e98c622ab20
History
Date User Action Args
2015-09-23 01:25:41steve.dowersetstatus: open -> closed
resolution: fixed
stage: resolved
2015-09-23 00:01:49python-devsetnosy: + python-dev
messages: + msg251363
2015-09-22 22:19:48steve.dowersetassignee: steve.dower
messages: + msg251357
2015-09-15 12:33:33thijsvandiensetfiles: + Python 3.5.0 (32-bit)_20150915141555.log

messages: + msg250764
2015-09-15 12:28:20thijsvandiencreate