classification
Title: Logging Documentation - dictConfig disable_existing_loggers
Type: enhancement Stage:
Components: Documentation Versions: Python 2.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: docs@python Nosy List: coderobot, docs@python, vinay.sajip
Priority: normal Keywords:

Created on 2015-09-15 10:28 by coderobot, last changed 2015-10-01 11:15 by vinay.sajip. This issue is now closed.

Messages (2)
msg250755 - (view) Author: Robin (coderobot) Date: 2015-09-15 10:28
logging.config.dictConfig appears to share the same parameter as logging.config.fileConfig - disable_existing_loggers.

This parameter is documented for fileConfig but not dictConfig.

Suggest update to dictConfig documentation section.
msg252019 - (view) Author: Vinay Sajip (vinay.sajip) * (Python committer) Date: 2015-10-01 11:15
This is mentioned in the documentation for dictConfig - see the bottom of the section at https://docs.python.org/2.7/library/logging.config.html#dictionary-schema-details
History
Date User Action Args
2015-10-01 11:15:33vinay.sajipsetstatus: open -> closed
resolution: not a bug
messages: + msg252019
2015-09-15 13:30:32r.david.murraysetnosy: + vinay.sajip
2015-09-15 10:28:32coderobotcreate