classification
Title: When you create a file using file(path, "w") if the filename is illegal it throws an irrelevant error message
Type: resource usage Stage:
Components: Versions: Python 2.5
process
Status: closed Resolution: wont fix
Dependencies: Superseder:
Assigned To: Nosy List: facundobatista, kobipe3, loewis
Priority: normal Keywords:

Created on 2008-03-29 15:55 by kobipe3, last changed 2008-03-29 16:34 by loewis. This issue is now closed.

Messages (3)
msg64703 - (view) Author: kobi (kobipe3) Date: 2008-03-29 15:56
It throws an IOError: ... No such file or directory: %path% instead of 
IOError: Invalid file name.
msg64705 - (view) Author: Facundo Batista (facundobatista) * (Python committer) Date: 2008-03-29 16:10
How do you know, in a cross platform way, that the name is illegal
instead that the file or directory does not exist?
msg64706 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2008-03-29 16:34
This is not a bug in Python. The error that you get comes directly from
the operating system/C library, so please complain to your system vendor.
History
Date User Action Args
2008-03-29 16:34:01loewissetstatus: open -> closed
resolution: wont fix
messages: + msg64706
nosy: + loewis
2008-03-29 16:10:01facundobatistasetnosy: + facundobatista
messages: + msg64705
2008-03-29 15:56:45kobipe3setmessages: + msg64703
2008-03-29 15:55:35kobipe3create