classification
Title: tokenize doesn't handle __future__.unicode_literals correctly
Type: Stage:
Components: Library (Lib) Versions: Python 2.6
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: Nosy List: amaury.forgeotdarc, christian.heimes
Priority: normal Keywords:

Created on 2008-03-27 11:50 by christian.heimes, last changed 2018-04-23 01:09 by lukasz.langa. This issue is now closed.

Pull Requests
URL Status Linked Edit
PR 6572 closed lukasz.langa, 2018-04-23 01:09
Messages (2)
msg64582 - (view) Author: Christian Heimes (christian.heimes) * (Python committer) Date: 2008-03-27 11:50
See r61976

Clear the blacklist and run the test with 

  ./python Lib/test/regrtest.py -uall test_tokenize

to reproduce the issue.
msg64609 - (view) Author: Amaury Forgeot d'Arc (amaury.forgeotdarc) * (Python committer) Date: 2008-03-27 23:24
Actually, the problem is that untokenize does not put spaces between two
consecutive string literals:

'' '' => ''''

Corrected with r61979.
Will backport
History
Date User Action Args
2018-04-23 01:09:05lukasz.langasetpull_requests: + pull_request6271
2008-03-27 23:24:21amaury.forgeotdarcsetstatus: open -> closed
resolution: fixed
messages: + msg64609
nosy: + amaury.forgeotdarc
2008-03-27 11:50:02christian.heimescreate