classification
Title: freeze.py doesn't work on x86_64 Linux out of the box
Type: Stage: resolved
Components: Demos and Tools Versions: Python 3.2, Python 3.3, Python 3.4, Python 3.5
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: Nosy List: termim, vstinner
Priority: normal Keywords: patch

Created on 2015-08-15 03:13 by termim, last changed 2021-05-14 12:20 by vstinner. This issue is now closed.

Files
File name Uploaded Description Edit
freeze-lib64.diff termim, 2015-08-15 03:13 patch against Python-3.4.3 review
Messages (3)
msg248633 - (view) Author: Mikhail Terekhov (termim) * Date: 2015-08-15 03:13
On 64-bit Linux freeze.py uses lib instead of lib64 when constructing
path to Makefile etc. Using sysconfig fixes this issue.


Without encodings.ascii resulting program fails with the following error:

Fatal Python error: Py_Initialize: Unable to get the locale encoding
LookupError: unknown encoding: ANSI_X3.4-1968
Aborted

Attached patch fixes both issues.
msg363890 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2020-03-11 09:17
bpo-1294959 has been fixed by commit 8510f430781118d9b603c3a2f06945d6ebc5fe42: Python 3.9 now has sys.platlibdir which will be equal to "lib64" on Fedora and SuSE on 64-bit systems.
msg393645 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2021-05-14 12:20
I consider that the issue is now fixed. If it's not the case, please reopen the issue (or open a new issue).
History
Date User Action Args
2021-05-14 12:20:23vstinnersetstatus: open -> closed
resolution: fixed
messages: + msg393645

stage: resolved
2020-03-11 09:17:43vstinnersetmessages: + msg363890
2019-05-15 03:00:42vstinnersetnosy: + vstinner
2015-08-15 03:13:46termimcreate