classification
Title: Cosmetic patch for warning "unused variable"
Type: Stage:
Components: Extension Modules Versions: Python 3.0
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: Nosy List: georg.brandl, ocean-city
Priority: normal Keywords: patch

Created on 2008-03-25 17:00 by ocean-city, last changed 2008-03-26 09:00 by georg.brandl. This issue is now closed.

Files
File name Uploaded Description Edit
fix_warning.patch ocean-city, 2008-03-25 17:00
Messages (4)
msg64499 - (view) Author: Hirokazu Yamamoto (ocean-city) * (Python committer) Date: 2008-03-25 17:00
"int i,j;" in inner block is hiding "Py_ssize_t i,j;"
msg64502 - (view) Author: Georg Brandl (georg.brandl) * (Python committer) Date: 2008-03-25 17:54
This seems to be already fixed in trunk. Can you confirm?
msg64541 - (view) Author: Hirokazu Yamamoto (ocean-city) * (Python committer) Date: 2008-03-26 04:38
I've confirmed trunk doesn't have this problem.

Probably this is merge issue. r57928 changed the position of "int i,j"
in py3k, but not changed in trunk, so when r61864 was merged into py3k
some kind of conflict happened.
msg64546 - (view) Author: Georg Brandl (georg.brandl) * (Python committer) Date: 2008-03-26 09:00
Thanks, fixed in r61927.
History
Date User Action Args
2008-03-26 09:00:21georg.brandlsetstatus: open -> closed
resolution: fixed
messages: + msg64546
keywords: patch, patch
2008-03-26 04:38:23ocean-citysetkeywords: patch, patch
messages: + msg64541
2008-03-25 17:54:50georg.brandlsetkeywords: patch, patch
nosy: + georg.brandl
messages: + msg64502
2008-03-25 17:00:04ocean-citycreate