classification
Title: Consistent failure in test_asyncio on Windows 7 buildbot
Type: crash Stage: resolved
Components: Versions:
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: Nosy List: Yury.Selivanov, gvanrossum, larry, python-dev, steve.dower, vstinner, yselivanov
Priority: critical Keywords:

Created on 2015-08-09 10:26 by larry, last changed 2015-08-10 15:50 by yselivanov. This issue is now closed.

Messages (11)
msg248320 - (view) Author: Larry Hastings (larry) * (Python committer) Date: 2015-08-09 10:26
The Python 3.5 buildbot for Windows 7 consistently fails during test_asyncio.  The buildbots are here:

http://buildbot.python.org/all/waterfall?category=3.5.stable

An example log file:

http://buildbot.python.org/all/builders/x86%20Windows7%203.5/builds/173/steps/test/logs/stdio

The error is at the end and looks like this:

    test_winsocketpair_ipv6 (test.test_asyncio.test_windows_utils.WinsocketpairTests) ... D:\cygwin\home\db3l\buildarea\3.5.bolen-windows7\build\lib\asyncio\base_subprocess.py:122: ResourceWarning: unclosed transport <_WindowsSubprocessTransport pid=3388 running>
      warnings.warn("unclosed transport %r" % self, ResourceWarning)
    test test_asyncio failed
    ok

Who's the expert for the asyncio implementation on Windows?  Could one of you guys nosy him/her on the bug?
msg248323 - (view) Author: Guido van Rossum (gvanrossum) * (Python committer) Date: 2015-08-09 12:33
Probably Vincent knows? FWIW the actual failure from the log file is:

FAIL: test_popen_error (test.test_asyncio.test_subprocess.SubprocessProactorTests)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "D:\cygwin\home\db3l\buildarea\3.5.bolen-windows7\build\lib\test\test_asyncio\test_subprocess.py", line 428, in test_popen_error
    self.loop.run_until_complete(create)
AssertionError: ZeroDivisionError not raised

The test refers to issue #24763.
msg248324 - (view) Author: Guido van Rossum (gvanrossum) * (Python committer) Date: 2015-08-09 12:41
Actually, this seems to be Yuri's mistake -- in rev 99550a01fa6e (in the 3.4 case, I suppose it's been merged into 3.5 and 3.6) he (accidentally, I assume) reverted Victor's (not Vincent's -- sorry!) fix from issue #24763. But apparently Victor didn't copy that fix to the upstream asyncio repo.
msg248337 - (view) Author: Larry Hastings (larry) * (Python committer) Date: 2015-08-09 20:47
We're retagging 3.5.0rc1 to fix this and one other regression.  Can someone step up and get this fix checked in in the next six or eight hours?  You can just check in to the 3.5 branch on hg.python.org/cpython like normal (you won't have to use Bitbucket and "pull requests" for this).
msg248338 - (view) Author: Yury Selivanov (Yury.Selivanov) * Date: 2015-08-09 21:22
I can commit the fix in an hour or so.
msg248342 - (view) Author: Roundup Robot (python-dev) (Python triager) Date: 2015-08-09 22:22
New changeset 2648dddd3248 by Yury Selivanov in branch '3.4':
Issue #24763: Fix asyncio test on Windows (fix reverted change)
https://hg.python.org/cpython/rev/2648dddd3248

New changeset aa527ee0d27f by Yury Selivanov in branch '3.5':
Merge 3.4 (issues #24835, #24763)
https://hg.python.org/cpython/rev/aa527ee0d27f

New changeset f304ba9425a3 by Yury Selivanov in branch 'default':
Merge 3.5 (issues #24835, #24763)
https://hg.python.org/cpython/rev/f304ba9425a3
msg248343 - (view) Author: Yury Selivanov (yselivanov) * (Python committer) Date: 2015-08-09 22:23
Guido, thanks for investigating this.

Larry, it should be fixed now (although I don't have a windows machine at hand to test it)
msg248344 - (view) Author: Larry Hastings (larry) * (Python committer) Date: 2015-08-09 22:30
I don't have one either.  But that's why we've got buildbots.  The Windows 7 buildbot, where I first noticed the regression, is here:

http://buildbot.python.org/all/builders/x86%20Windows7%203.5

It should be done testing your patch 1 hour and 15 minutes from now.
msg248349 - (view) Author: Larry Hastings (larry) * (Python committer) Date: 2015-08-10 03:40
The buildbot passes the test!  Hooray!
msg248351 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2015-08-10 08:33
Le 9 août 2015 14:41, "Guido van Rossum" <report@bugs.python.org> a écrit :
> But apparently Victor didn't copy that fix to the upstream asyncio repo.

Yeah sorry about that. Hopefully it's now fixed.

Yury: be careful when synchonizing github and cpython code. It's common to
have changes only on one side.
msg248360 - (view) Author: Yury Selivanov (yselivanov) * (Python committer) Date: 2015-08-10 15:50
> Yury: be careful when synchonizing github and cpython code. It's common to
have changes only on one side.

Victor, I agree.  But let's make sure that it's no more "common" to have two repos out of sync.  I shouldn't sync your changes (and you, likewise, shouldn't sync mine) because I'm not really familiar with them, and it is sometimes hard to guess what's going on.  Let's stick to the workflow, please.
History
Date User Action Args
2015-08-10 15:50:51yselivanovsetmessages: + msg248360
2015-08-10 08:33:05vstinnersetmessages: + msg248351
2015-08-10 03:40:14larrysetmessages: + msg248349
2015-08-09 22:30:32larrysetmessages: + msg248344
2015-08-09 22:24:05yselivanovsetstatus: open -> closed
resolution: fixed
stage: needs patch -> resolved
2015-08-09 22:23:53yselivanovsetmessages: + msg248343
2015-08-09 22:22:43python-devsetnosy: + python-dev
messages: + msg248342
2015-08-09 21:22:12Yury.Selivanovsetnosy: + Yury.Selivanov
messages: + msg248338
2015-08-09 20:47:11larrysetmessages: + msg248337
2015-08-09 12:41:25gvanrossumsetnosy: + yselivanov
messages: + msg248324
2015-08-09 12:33:27gvanrossumsetmessages: + msg248323
2015-08-09 10:26:26larrycreate