This issue tracker has been migrated to GitHub, and is currently read-only.
For more information, see the GitHub FAQs in the Python's Developer Guide.

classification
Title: Import Error (undefined symbol: PyFloat_Type) when Importing math Module on Shared Build
Type: Stage: resolved
Components: Installation Versions: Python 2.7
process
Status: closed Resolution: out of date
Dependencies: Superseder:
Assigned To: Nosy List: ZackerySpytz, david-narvaez
Priority: normal Keywords:

Created on 2015-08-03 00:31 by david-narvaez, last changed 2022-04-11 14:58 by admin. This issue is now closed.

Messages (2)
msg247915 - (view) Author: David E. Narvaez (david-narvaez) Date: 2015-08-03 00:31
The original bug report can be found at https://bugs.kde.org/show_bug.cgi?id=335965. I was not able to reproduce this on Gentoo until the Fedora maintainer commented they build their Python with --enable-shared. At that point, I built two copies of Python 2.7 from git, one with defaults and one with --enable-shared. When I run the application with PYTHONHOME=/path/to/defualt/install it runs correctly, and when I run the application with PYTHONHOME=/path/to/shared/install I can reproduce the bug.

Is there something missing in the linking of this application in order for it to use a Python installation built with --enable-shared?
msg375274 - (view) Author: Zackery Spytz (ZackerySpytz) * (Python triager) Date: 2020-08-12 17:58
Python 2.7 is no longer supported, so I think this issue should be closed.
History
Date User Action Args
2022-04-11 14:58:19adminsetgithub: 68971
2020-08-13 08:30:23ned.deilysetstatus: open -> closed
resolution: out of date
stage: resolved
2020-08-12 17:58:59ZackerySpytzsetnosy: + ZackerySpytz
messages: + msg375274
2015-08-03 00:31:57david-narvaezcreate