classification
Title: namedtuple breaks refleak tests
Type: crash Stage:
Components: Library (Lib), Tests Versions: Python 2.6
process
Status: closed Resolution: out of date
Dependencies: Superseder:
Assigned To: rhettinger Nosy List: belopolsky, christian.heimes, rhettinger
Priority: high Keywords:

Created on 2008-03-21 18:54 by christian.heimes, last changed 2008-05-08 20:43 by christian.heimes. This issue is now closed.

Messages (3)
msg64258 - (view) Author: Christian Heimes (christian.heimes) * (Python committer) Date: 2008-03-21 18:54
trunk$ ./python Lib/test/regrtest.py -ubsddb,network -R::    
test_collections
test_collections
beginning 9 repetitions
123456789
test test_collections failed -- Traceback (most recent call last):
  File "/home/heimes/dev/python/trunk/Lib/doctest.py", line 2131, in runTest
    raise self.failureException(self.format_failure(new.getvalue()))
AssertionError: Failed doctest test for collections.namedtuple
  File "/home/heimes/dev/python/trunk/Lib/collections.py", line 13, in
namedtuple

----------------------------------------------------------------------
File "/home/heimes/dev/python/trunk/Lib/collections.py", line 16, in
collections.namedtuple
Failed example:
    Point = namedtuple('Point', 'x y')
Exception raised:
    Traceback (most recent call last):
      File "/home/heimes/dev/python/trunk/Lib/doctest.py", line 1231, in
__run
        compileflags, 1) in test.globs
      File "<doctest collections.namedtuple[0]>", line 1, in <module>
        Point = namedtuple('Point', 'x y')
    NameError: name 'namedtuple' is not defined
msg64456 - (view) Author: Alexander Belopolsky (belopolsky) * (Python committer) Date: 2008-03-25 04:42
This is a duplicate of issue2223.  (See msg63244.)
msg66446 - (view) Author: Christian Heimes (christian.heimes) * (Python committer) Date: 2008-05-08 20:43
The tests are passing again.
History
Date User Action Args
2008-05-08 20:43:27christian.heimessetstatus: open -> closed
resolution: out of date
messages: + msg66446
2008-03-25 04:42:52belopolskysetnosy: + belopolsky
messages: + msg64456
2008-03-21 18:54:50christian.heimescreate