classification
Title: Python 2.6 refleak test issues
Type: crash Stage:
Components: Tests Versions: Python 2.6
process
Status: closed Resolution: duplicate
Dependencies: Superseder: regrtest.py -R not working
View: 2223
Assigned To: Nosy List: belopolsky, christian.heimes
Priority: high Keywords:

Created on 2008-03-21 18:51 by christian.heimes, last changed 2008-12-05 09:59 by georg.brandl. This issue is now closed.

Messages (2)
msg64257 - (view) Author: Christian Heimes (christian.heimes) * (Python committer) Date: 2008-03-21 18:51
linux-i686-2.6
Revision 61704.
Ubuntu 7.10 on i586 machine
gcc-Version 4.1.3 20070929 (prerelease) (Ubuntu 4.1.2-16ubuntu2)

trunk$ ./python Lib/test/regrtest.py -ubsddb,network -R::
[...]
311 tests OK.
7 tests failed:
    test_collections test_cprofile test_frozen test_logging test_pkg
    test_profile test_tcl
27 tests skipped:
    test_aepack test_al test_applesingle test_bsddb185 test_cd test_cl
    test_codecmaps_cn test_codecmaps_hk test_codecmaps_jp
    test_codecmaps_kr test_codecmaps_tw test_curses test_gl
    test_imageop test_imgfile test_linuxaudiodev test_macostools
    test_normalization test_ossaudiodev test_pep277 test_py3kwarn
    test_scriptpackages test_startfile test_sunaudiodev test_winreg
    test_winsound test_zipfile64
Those skips are all expected on linux2.

trunk$ cat reflog.txt
test_smtplib leaked [86, -86, 80, -80] references, sum=0
test_socket_ssl leaked [0, 123, -123, 0] references, sum=0
test_threading leaked [0, 0, 0, -86] references, sum=-86
test_urllib2_localnet leaked [3, 171, -165, 3] references, sum=12
msg64457 - (view) Author: Alexander Belopolsky (belopolsky) * (Python committer) Date: 2008-03-25 04:46
This is a duplicate of issue2223.
History
Date User Action Args
2008-12-05 09:59:01georg.brandlsetstatus: open -> closed
resolution: duplicate
superseder: regrtest.py -R not working
2008-03-25 04:46:29belopolskysetnosy: + belopolsky
messages: + msg64457
2008-03-21 18:51:59christian.heimescreate