classification
Title: Documentation regressions from adding subprocess.run()
Type: behavior Stage: resolved
Components: Documentation Versions: Python 3.6, Python 3.5
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: docs@python Nosy List: berker.peksag, docs@python, martin.panter, python-dev, serhiy.storchaka, takluyver
Priority: normal Keywords: patch

Created on 2015-06-10 04:04 by martin.panter, last changed 2015-07-25 11:29 by berker.peksag. This issue is now closed.

Files
File name Uploaded Description Edit
high-args.patch martin.panter, 2015-06-10 04:04 review
high-args.v2.patch martin.panter, 2015-06-29 13:25 review
Messages (6)
msg245111 - (view) Author: Martin Panter (martin.panter) * (Python committer) Date: 2015-06-10 04:04
After the documentation was rearranged by Issue 23342 (revision f0a00ee094ff), the “older high-level APIs” lost the paragraphs that said “The arguments shown above are merely the most common ones”. Given the limited signatures of call(), check_call() and check_output(), it is now too easy to assume that these functions do not accept the less-common Popen arguments.

Also, in that issue I discovered an awkward edge case: there is actually no default value for the check_output() input parameter. Without an “input” parameter, the subprocess inherits its parent’s input, but input=None is equivalent to passing an empty string of the correct type.

This patch hopefully fixes both problems.
msg245138 - (view) Author: Thomas Kluyver (takluyver) * Date: 2015-06-10 19:04
Thanks, this looks good to me.
msg245833 - (view) Author: Berker Peksag (berker.peksag) * (Python committer) Date: 2015-06-25 21:32
LGTM, too. I just left a comment on Rietveld.

Thanks!
msg245935 - (view) Author: Martin Panter (martin.panter) * (Python committer) Date: 2015-06-29 13:25
New patch dropping the [, input] parameter from the signature. I also removed the bit about *stdout*, since it should be obvious from the equivalent run() call given, and equally applies to *check*.
msg247343 - (view) Author: Roundup Robot (python-dev) (Python triager) Date: 2015-07-25 11:28
New changeset bedff93d778d by Berker Peksag in branch '3.5':
Issue #24420: Fix documentation regression introduced by f0a00ee094ff.
https://hg.python.org/cpython/rev/bedff93d778d

New changeset 9b17df697a3c by Berker Peksag in branch 'default':
Issue #24420: Fix documentation regression introduced by f0a00ee094ff.
https://hg.python.org/cpython/rev/9b17df697a3c
msg247344 - (view) Author: Berker Peksag (berker.peksag) * (Python committer) Date: 2015-07-25 11:29
Thanks Martin.
History
Date User Action Args
2015-07-25 11:29:13berker.peksagsetstatus: open -> closed
resolution: fixed
messages: + msg247344

stage: commit review -> resolved
2015-07-25 11:28:19python-devsetnosy: + python-dev
messages: + msg247343
2015-06-29 13:25:29martin.pantersetfiles: + high-args.v2.patch

messages: + msg245935
2015-06-25 21:32:42berker.peksagsetmessages: + msg245833
2015-06-22 06:39:33martin.pantersetstage: patch review -> commit review
2015-06-11 07:01:29serhiy.storchakasetnosy: + serhiy.storchaka
2015-06-10 19:04:03takluyversetmessages: + msg245138
2015-06-10 04:38:58berker.peksagsetnosy: + berker.peksag

stage: patch review
2015-06-10 04:04:16martin.pantercreate