classification
Title: Distutils runtime_library_dirs broken on Windows
Type: behavior Stage: resolved
Components: Distutils Versions: Python 3.4, Python 3.5, Python 2.7
process
Status: closed Resolution: out of date
Dependencies: Superseder:
Assigned To: tarek Nosy List: eric.araujo, janssen, lgautier, loewis, rpetrov, steve.dower, tarek
Priority: high Keywords:

Created on 2008-03-20 20:23 by janssen, last changed 2021-02-03 18:29 by steve.dower. This issue is now closed.

Messages (6)
msg64200 - (view) Author: Bill Janssen (janssen) * (Python committer) Date: 2008-03-20 20:23
The distutils.unixcompiler.runtime_library_dirs() function, used when
compiling with MinGW or Cygwin on Windows, fails catastrophically
because the return result of sysconfig.get_config_var("CC") returns
None.  It should probably be prepared for that eventuality.
msg67039 - (view) Author: Laurent Gautier (lgautier) Date: 2008-05-18 20:20
The bug is still here with Python 2.5.2.

I anyone want to have it work urgently, there is a quick but very ugly
fix: add
g['CC'] = 'gcc' 
into the function _init_nt() in the file Lib\distutils\sysconfig.py
of the Python install.
msg81838 - (view) Author: Tarek Ziadé (tarek) * (Python committer) Date: 2009-02-12 23:33
Bill, do you have a example to reproduce the problem so I can write the
test ?

Laurent, right. but we need to figure out how to get the CC name in
MinGW/Cygwin environment.

I am not familiar with them. Does CC gets set in the environment ? if so
we could use a similar mechanism that we have in customize_compiler()
msg82981 - (view) Author: Bill Janssen (janssen) * (Python committer) Date: 2009-03-01 20:18
No, Tarek, I don't have a MinGW machine right now.  But it should be
easy to reproduce; just invoke that call I originally reported.  The
distutils code is just making assumptions that it shouldn't be making.
msg82982 - (view) Author: Bill Janssen (janssen) * (Python committer) Date: 2009-03-01 20:22
Tarek writes:

> Laurent, right. but we need to figure out how to get the CC name in
> MinGW/Cygwin environment.

> I am not familiar with them.

Since this bug is specifically about that environment, shouldn't it be
handled by someone who is familiar with them?  Not objecting, here, but
it seems unlikely to result in a rapid fix.  And MinGW and Cygwin are
pretty different, IMHO; don't mix them together here.
msg386399 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2021-02-03 18:29
Distutils is now deprecated (see PEP 632) and all tagged issues are being closed. From now until removal, only release blocking issues will be considered for distutils.

If this issue does not relate to distutils, please remove the component and reopen it. If you believe it still requires a fix, most likely the issue should be re-reported at https://github.com/pypa/setuptools
History
Date User Action Args
2021-02-03 18:29:00steve.dowersetstatus: open -> closed

nosy: + steve.dower
messages: + msg386399

resolution: out of date
stage: resolved
2014-07-09 21:51:28BreamoreBoysetversions: + Python 3.4, Python 3.5, - Python 3.1, Python 3.2
2011-02-04 03:46:07belopolskysetnosy: loewis, janssen, tarek, lgautier, eric.araujo, rpetrov
type: crash -> behavior
2010-08-21 20:29:31eric.araujosetnosy: + loewis, eric.araujo

versions: - Python 2.6
2010-05-11 20:46:45terry.reedysetversions: + Python 3.2, - Python 2.3, Python 3.0
2009-03-01 20:22:04janssensetmessages: + msg82982
2009-03-01 20:18:58janssensetmessages: + msg82981
2009-02-12 23:33:44tareksetmessages: + msg81838
versions: + Python 3.1, Python 2.7, - Python 2.5, Python 2.4
2009-02-11 20:21:03rpetrovsetnosy: + rpetrov
2009-02-11 04:40:45ajaksu2setassignee: tarek
nosy: + tarek
2008-05-18 20:20:32lgautiersetnosy: + lgautier
messages: + msg67039
2008-03-20 20:23:56janssensetpriority: high
type: crash
components: + Distutils
versions: + Python 2.6, Python 2.5, Python 2.4, Python 2.3, Python 3.0
2008-03-20 20:23:14janssencreate