classification
Title: Null pointer dereferences in C OrderedDict
Type: crash Stage: resolved
Components: Library (Lib) Versions: Python 3.6, Python 3.5
process
Status: closed Resolution: duplicate
Dependencies: Superseder: unchecked return value in C OrderedDict
View: 24347
Assigned To: eric.snow Nosy List: Arfrever, christian.heimes, eric.snow, yselivanov
Priority: release blocker Keywords:

Created on 2015-06-01 16:24 by eric.snow, last changed 2015-06-02 01:12 by eric.snow. This issue is now closed.

Messages (2)
msg244599 - (view) Author: Eric Snow (eric.snow) * (Python committer) Date: 2015-06-01 16:24
(from msg244587 in issue16991)

Coverity has found an issue in odict, too:

*** CID 1302699:  Null pointer dereferences  (NULL_RETURNS)
/Objects/odictobject.c: 1316 in odict_copy()
1310             od_copy = PyObject_CallFunctionObjArgs((PyObject *)Py_TYPE(od), NULL);
1311         if (od_copy == NULL)
1312             return NULL;
1313     
1314         if (PyODict_CheckExact(od)) {
1315             _odict_FOREACH(od, node) {
>>>     CID 1302699:  Null pointer dereferences  (NULL_RETURNS)
>>>     Dereferencing a pointer that might be null "PyDict_GetItem((PyObject *)(PyObject *)od, node->key)" when calling "PyODict_SetItem".
1316                 int res = PyODict_SetItem((PyObject *)od_copy,
1317                                           _odictnode_KEY(node),
1318                                           _odictnode_VALUE(node, od));
1319                 if (res != 0)
1320                     goto fail;
1321             }
msg244629 - (view) Author: Eric Snow (eric.snow) * (Python committer) Date: 2015-06-02 01:12
Correct me if I'm wrong, but this is a duplicate of the bug Stefan reported in issue24347.
History
Date User Action Args
2015-06-02 01:12:07eric.snowsetstatus: open -> closed
superseder: unchecked return value in C OrderedDict
messages: + msg244629

resolution: duplicate
stage: needs patch -> resolved
2015-06-01 17:24:30Arfreversetnosy: + Arfrever
2015-06-01 16:27:30yselivanovsetnosy: + yselivanov
2015-06-01 16:24:34eric.snowcreate