classification
Title: Extension modules with single-letter names can't be loaded
Type: behavior Stage: resolved
Components: Versions: Python 3.6, Python 3.5
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: Nosy List: brett.cannon, encukou, eric.snow, martin.panter, ncoghlan, python-dev
Priority: release blocker Keywords: patch

Created on 2015-05-29 19:49 by encukou, last changed 2015-05-29 23:44 by python-dev. This issue is now closed.

Files
File name Uploaded Description Edit
fix-short-names.patch encukou, 2015-05-29 19:49 review
Messages (4)
msg244403 - (view) Author: Petr Viktorin (encukou) * Date: 2015-05-29 19:49
A regression in the PEP 489 implementation prevents loading extension modules with single-character names (because length-1 bytestrings are interned).

Here is a fix. It would be great to have it in 3.5.0b2.
msg244424 - (view) Author: Roundup Robot (python-dev) Date: 2015-05-29 22:11
New changeset 784f372d701a by Benjamin Peterson in branch '3.5':
fix importing one char extension modules (closes #24328)
https://hg.python.org/cpython/rev/784f372d701a

New changeset d89bab1f160e by Benjamin Peterson in branch 'default':
merge 3.5 (#24328)
https://hg.python.org/cpython/rev/d89bab1f160e
msg244430 - (view) Author: Martin Panter (martin.panter) * (Python committer) Date: 2015-05-29 23:10
Two minor comments on Reitveld. Looks like you alreay fixed one of them in the actual commit.
msg244431 - (view) Author: Roundup Robot (python-dev) Date: 2015-05-29 23:44
New changeset 8428cb297d15 by Benjamin Peterson in branch '3.5':
use assert method (#24328)
https://hg.python.org/cpython/rev/8428cb297d15
History
Date User Action Args
2015-05-29 23:44:58python-devsetmessages: + msg244431
2015-05-29 23:10:24martin.pantersettype: behavior

messages: + msg244430
nosy: + martin.panter
2015-05-29 22:11:53python-devsetstatus: open -> closed

nosy: + python-dev
messages: + msg244424

resolution: fixed
stage: commit review -> resolved
2015-05-29 20:10:45r.david.murraysetpriority: normal -> release blocker
stage: commit review
2015-05-29 19:49:52encukoucreate