classification
Title: Logging module hides user code errors (bare except)
Type: behavior Stage:
Components: Library (Lib) Versions: Python 2.4
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: bradallen, vinay.sajip
Priority: normal Keywords:

Created on 2008-03-19 16:55 by bradallen, last changed 2008-04-02 21:00 by vinay.sajip. This issue is now closed.

Messages (3)
msg64069 - (view) Author: Brad Allen (bradallen) Date: 2008-03-19 16:55
The logging module contains several bare except statements. It's
understandable that the logging module should be completely silent, but
in the case of logging.config, the bare except can make it very
difficult to identify when there is a problem with a customer handler or
even with configuration.

These are the offending lines (lines 133-134): 

except: #if an error occurs when instantiating a handler, too bad
    pass    #this could happen e.g. because of lack of privileges

Maybe this should only catch OSError, so that other problems will
generate a failure at this point and show the correct traceback. My
experience is that there is usually a failure anyway when there is a
configuration problem, but the error is usually misleading.

By the way, exceptions generated here seem to mainly occur when a Python
script is first starting up, as it involves the initial configuration. I
am not convinced that the logging module should be silent at that stage.
msg64070 - (view) Author: Brad Allen (bradallen) Date: 2008-03-19 16:56
in the previous post, please replace the word 'customer' with the word
'user'
msg64877 - (view) Author: Vinay Sajip (vinay.sajip) * (Python committer) Date: 2008-04-02 21:00
This has already been fixed in trunk.
History
Date User Action Args
2008-04-02 21:00:07vinay.sajipsetstatus: open -> closed
resolution: not a bug
messages: + msg64877
nosy: + vinay.sajip
2008-03-19 16:56:33bradallensetmessages: + msg64070
2008-03-19 16:55:27bradallencreate