classification
Title: asyncio: support 'async for' for StreamReader
Type: enhancement Stage: resolved
Components: asyncio Versions: Python 3.5
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: yselivanov Nosy List: asvetlov, gvanrossum, python-dev, vstinner, yselivanov
Priority: normal Keywords: patch

Created on 2015-05-13 17:04 by yselivanov, last changed 2015-05-13 18:39 by yselivanov. This issue is now closed.

Files
File name Uploaded Description Edit
aread.patch yselivanov, 2015-05-13 17:04 review
Messages (3)
msg243105 - (view) Author: Yury Selivanov (yselivanov) * (Python committer) Date: 2015-05-13 17:04
This patch adds support for 'async for' syntax for StreamReader.

The issue is opened on bugs.python.org instead of asyncio GH (same as issue #24178)
msg243113 - (view) Author: Roundup Robot (python-dev) Date: 2015-05-13 18:24
New changeset 4f6978343ef6 by Yury Selivanov in branch 'default':
Issue 24179: Support 'async for' for asyncio.StreamReader.
https://hg.python.org/cpython/rev/4f6978343ef6
msg243114 - (view) Author: Yury Selivanov (yselivanov) * (Python committer) Date: 2015-05-13 18:39
Guido, thanks for review. Closing the issue.
History
Date User Action Args
2015-05-13 18:39:41yselivanovsetstatus: open -> closed
resolution: fixed
messages: + msg243114

stage: patch review -> resolved
2015-05-13 18:24:12python-devsetnosy: + python-dev
messages: + msg243113
2015-05-13 17:04:08yselivanovcreate