classification
Title: httplib
Type: behavior Stage: resolved
Components: Versions: Python 2.7
process
Status: closed Resolution: duplicate
Dependencies: Superseder: Missing size argument in readline() method for httplib's class LineAndFileWrapper
View: 17849
Assigned To: Nosy List: jitterman, r.david.murray
Priority: normal Keywords:

Created on 2015-05-12 19:23 by jitterman, last changed 2015-05-12 20:06 by r.david.murray. This issue is now closed.

Messages (2)
msg242998 - (view) Author: JitterMan (jitterman) Date: 2015-05-12 19:23
In python2.7.9, httplib.py, on line 780, makes a call to:

    line = response.fp.readline(_MAXLINE + 1)

This ends up calling a function defined on line 1362 in the same file:

    def readline(self):

Notice the argument mismatch. The call passes two arguments, but the function defines only one. This can be 'fixed' by changing the definition to:

    def readline(self, size=None):
msg243004 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2015-05-12 20:06
This is a duplicate of issue 17849.
History
Date User Action Args
2015-05-12 20:06:04r.david.murraysetstatus: open -> closed

superseder: Missing size argument in readline() method for httplib's class LineAndFileWrapper
nosy: + r.david.murray

messages: + msg243004
type: crash -> behavior
resolution: duplicate
stage: resolved
2015-05-12 19:23:59jittermancreate