classification
Title: Backport 3.0 struct module changes to 2.6
Type: enhancement Stage: test needed
Components: Library (Lib) Versions: Python 2.7
process
Status: closed Resolution: out of date
Dependencies: Superseder:
Assigned To: Nosy List: ajaksu2, mark.dickinson, teoliphant
Priority: low Keywords:

Created on 2008-03-18 16:04 by teoliphant, last changed 2010-06-14 14:24 by mark.dickinson. This issue is now closed.

Messages (3)
msg63931 - (view) Author: Travis Oliphant (teoliphant) * (Python committer) Date: 2008-03-18 16:04
The changes to the struct module in PEP 3118 should be backported to 2.6
as it is backward compatible and would smooth the transition to 3.0.  It
is lower priority and could wait until 2.7
msg87923 - (view) Author: Daniel Diniz (ajaksu2) (Python triager) Date: 2009-05-16 20:33
This risks missing 2.x if nobody adopts the implementation of PEP 3118
in 3.x: 2.7 might be the last 2.x release.
msg107788 - (view) Author: Mark Dickinson (mark.dickinson) * (Python committer) Date: 2010-06-14 14:24
It's too late to backport any new features to 2.x.
History
Date User Action Args
2010-06-14 14:24:45mark.dickinsonsetstatus: open -> closed

nosy: + mark.dickinson
messages: + msg107788

resolution: out of date
2009-05-16 20:33:56ajaksu2setpriority: low

type: enhancement
versions: + Python 2.7, - Python 2.6
nosy: + ajaksu2

messages: + msg87923
stage: test needed
2008-03-18 16:04:55teoliphantcreate