classification
Title: Idle autocomplete: enter or clicking does not select the option
Type: behavior Stage: resolved
Components: IDLE Versions: Python 3.5
process
Status: closed Resolution: duplicate
Dependencies: Superseder: IDLE code completion window can hang or misbehave with mouse
View: 15786
Assigned To: Nosy List: Al.Sweigart, terry.reedy
Priority: normal Keywords:

Created on 2015-04-14 18:52 by Al.Sweigart, last changed 2015-04-17 21:31 by terry.reedy. This issue is now closed.

Messages (2)
msg240986 - (view) Author: Al Sweigart (Al.Sweigart) * Date: 2015-04-14 18:52
Currently, when you press Ctrl+Space or select Edit > Show Completions, a dropdown menu appears and lets you select an autocomplete option.

If you press Tab, the highlighted option in the dropdown is selected and your typing autocompletes. However, pressing enter (which is a natural way to select an option) does not work. Instead of newline is entered, which is an annoyance.

Also, clicking on the item with the mouse does not select an item from the dropdown either.
msg241367 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2015-04-17 21:31
I have noticed ;-).  TAB TAB is required to select, which is slightly obnoxious.  Click within the box closes it, which is useless and annoying.  Scrollwheel  moves the entries but not the selection highlight, making it mostly useless  These behaviors are mostly contrary to the doc and are overt bugs.  Some of the bugginess appears specific to Windows.

This issue is a duplicate of #15786, so I am closing it as such.
History
Date User Action Args
2015-04-17 21:31:21terry.reedysetstatus: open -> closed

superseder: IDLE code completion window can hang or misbehave with mouse
title: Pressing enter/return or clicking IDLE's autocomplete does not select the option -> Idle autocomplete: enter or clicking does not select the option
nosy: + terry.reedy

messages: + msg241367
resolution: duplicate
stage: resolved
2015-04-14 18:52:26Al.Sweigartcreate