classification
Title: Explain naming of the patch files in the bug tracker
Type: enhancement Stage: resolved
Components: Devguide Versions:
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: ezio.melotti, maciej.szulik, martin.panter, willingc
Priority: normal Keywords:

Created on 2015-04-13 23:02 by maciej.szulik, last changed 2016-01-12 08:56 by ezio.melotti. This issue is now closed.

Messages (5)
msg240800 - (view) Author: Maciej Szulik (maciej.szulik) * (Python triager) Date: 2015-04-13 23:02
During the lifecycle of a bug you do:
1. submit a patch
2. get a review with some comments
3. re-submit the patch

Talking to R. David Murray I got info there's no convention on naming those, I think it will be valuable to have some information in the devguide about that. 

Apparently you can either (when just fixing the patch) to stick with exactly the same name or add increasing suffix, eg. mypatch-1, mypatch-2, etc.).  Otherwise you can change the name, but the review system will be able to pick up the right patch, so you should not worry about that.
msg257399 - (view) Author: Ezio Melotti (ezio.melotti) * (Python committer) Date: 2016-01-03 06:32
FWIW I use e.g. issue1234.diff and if further patches are needed I add an increasing suffix: issue1234-2.diff, issue1234-3.diff, etc.
Since the name doesn't matter too much, I'm not sure it's worth documenting and/or enforcing a specific convention.
msg258014 - (view) Author: Maciej Szulik (maciej.szulik) * (Python triager) Date: 2016-01-11 20:50
Ezio, I've meant we should provide some guidelines with information the system will pick whatever they choose based on submission date. More informational than as a requirement.
msg258038 - (view) Author: Martin Panter (martin.panter) * (Python committer) Date: 2016-01-11 23:17
I guess if people wonder about this, you could at least say the naming doesn’t matter very much for the review system.

If I am generating my own patches, I try to name them with one or two concise words describing the particular solution, and then insert “.v2”, “.v3” etc for the revised patches. If I just gave them an issue number, it would get lost my Mercurial patch queue among a sea of other numbers. If I did not add the “.v2” revision number, people would have to refer to the patches by upload date rather than name or version.
msg258082 - (view) Author: Ezio Melotti (ezio.melotti) * (Python committer) Date: 2016-01-12 08:56
I think this is not worth fixing, for two reasons:
1) we are moving away from Rietveld;
2) even if we document it, most people won't go looking for naming conventions and just use reasonable names (and most of the times they will just work);
I'm therefore going to close this -- thanks anyway for the report.
History
Date User Action Args
2016-01-12 08:56:30ezio.melottisetstatus: open -> closed
type: enhancement
messages: + msg258082

resolution: not a bug
stage: resolved
2016-01-11 23:17:10martin.pantersetnosy: + martin.panter
messages: + msg258038
2016-01-11 20:57:29r.david.murraysetnosy: - r.david.murray
2016-01-11 20:50:26maciej.szuliksetmessages: + msg258014
2016-01-03 06:32:32ezio.melottisetnosy: + r.david.murray
messages: + msg257399
2015-04-13 23:02:17maciej.szulikcreate