classification
Title: test_warnings fails under -Werror
Type: Stage: resolved
Components: Tests Versions: Python 3.5
process
Status: closed Resolution: duplicate
Dependencies: Superseder: test_warnings fails with -Werror
View: 23027
Assigned To: Nosy List: brett.cannon, serhiy.storchaka
Priority: normal Keywords:

Created on 2015-03-31 16:56 by brett.cannon, last changed 2015-03-31 17:14 by serhiy.storchaka. This issue is now closed.

Messages (2)
msg239734 - (view) Author: Brett Cannon (brett.cannon) * (Python committer) Date: 2015-03-31 16:56
======================================================================
ERROR: test_warning_classes (__main__.CWarnTests)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/Users/bcannon/Repositories/cpython/pep-488/Lib/test/test_warnings.py", line 460, in test_warning_classes
    self.module.warn('good warning category', MyWarningClass)
WarnTests.test_warning_classes.<locals>.MyWarningClass: good warning category
msg239736 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2015-03-31 17:14
This is a duplicate of issue23027.
History
Date User Action Args
2015-03-31 17:14:07serhiy.storchakasetstatus: open -> closed

superseder: test_warnings fails with -Werror

nosy: + serhiy.storchaka
messages: + msg239736
resolution: duplicate
stage: needs patch -> resolved
2015-03-31 16:56:21brett.cannoncreate