classification
Title: "Generalization" misused in deque docs
Type: enhancement Stage:
Components: Documentation Versions: Python 3.6, Python 3.2, Python 3.3, Python 3.4, Python 3.5, Python 2.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: docs@python Nosy List: docs@python, rhettinger, rschwieb
Priority: normal Keywords:

Created on 2015-03-31 13:56 by rschwieb, last changed 2015-03-31 14:52 by rhettinger. This issue is now closed.

Messages (2)
msg239710 - (view) Author: (rschwieb) Date: 2015-03-31 13:56
This sentence in the deque docs (https://docs.python.org/2/library/collections.html#collections.deque) is not accurate: 

"Deques are a generalization of stacks and queues ..."

Deques are a _specialization_ of stacks and queues. Every deque is-a stack and is-a queue, but saying that "deques generalize stacks and queues" reverses this relationship.

On the surface it might seem minor, but I think it's worth correcting in this case since the "is-a" relationship is so fundamental in computer science. Besides, I'd like to think Python's awesome documentation is above using words to mean the opposite of what they mean :)
msg239720 - (view) Author: Raymond Hettinger (rhettinger) * (Python committer) Date: 2015-03-31 14:52
Sorry, I disagree.
History
Date User Action Args
2015-03-31 14:52:41rhettingersetstatus: open -> closed

nosy: + rhettinger
messages: + msg239720

resolution: not a bug
2015-03-31 13:56:02rschwiebcreate