classification
Title: test_subprocess fails if your sys.executable is on a path with a space in it
Type: Stage:
Components: Tests Versions: Python 2.6
process
Status: closed Resolution: accepted
Dependencies: Superseder:
Assigned To: gregory.p.smith Nosy List: gregory.p.smith, jeff.balogh, lanny, schmir
Priority: normal Keywords: easy, patch

Created on 2008-03-18 04:19 by lanny, last changed 2008-05-17 07:17 by gregory.p.smith. This issue is now closed.

Files
File name Uploaded Description Edit
test_subprocess-r61479.patch lanny, 2008-03-18 04:19 Patch
Messages (4)
msg63883 - (view) Author: Alan Brooks (lanny) Date: 2008-03-18 04:19
Patch attached that escapes the executable name so this test doesn't fail.
msg63956 - (view) Author: Ralf Schmitt (schmir) Date: 2008-03-18 18:02
I can confirm this issue. 2 tests fail without this patch. please apply.

here are the failing tests:
======================================================================
FAIL: test_args_string (test.test_subprocess.ProcessTestCase)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/ralf/tt tt/trunk/Lib/test/test_subprocess.py", line 544,
in test_args_string
    self.assertEqual(p.returncode, 47)
AssertionError: 126 != 47

======================================================================
FAIL: test_call_string (test.test_subprocess.ProcessTestCase)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/ralf/tt tt/trunk/Lib/test/test_subprocess.py", line 585,
in test_call_string
    self.assertEqual(rc, 47)
AssertionError: 126 != 47
msg64120 - (view) Author: Jeff Balogh (jeff.balogh) * Date: 2008-03-19 23:12
The patch works for me, and doesn't change anything except the test 
strings.

Not having spaces in your path also helps. ;)
msg66985 - (view) Author: Gregory P. Smith (gregory.p.smith) * (Python committer) Date: 2008-05-17 07:17
fixed in trunk r63405
History
Date User Action Args
2008-05-17 07:17:56gregory.p.smithsetstatus: open -> closed
priority: normal
resolution: accepted
messages: + msg66985
2008-03-20 16:47:08gregory.p.smithsetkeywords: + easy
assignee: gregory.p.smith
nosy: + gregory.p.smith
2008-03-19 23:12:46jeff.baloghsetnosy: + jeff.balogh
messages: + msg64120
2008-03-18 18:02:23schmirsetnosy: + schmir
messages: + msg63956
2008-03-18 04:19:14lannycreate