classification
Title: "make test" on clean py3 install on CentOS 6.2 - 2 tests fail
Type: behavior Stage: resolved
Components: Installation Versions: Python 3.4
process
Status: closed Resolution: duplicate
Dependencies: Superseder: Importing readline produces erroneous output
View: 19884
Assigned To: Nosy List: nagle, ned.deily, r.david.murray
Priority: normal Keywords:

Created on 2015-03-22 04:53 by nagle, last changed 2015-03-22 05:18 by ned.deily. This issue is now closed.

Messages (3)
msg238869 - (view) Author: John Nagle (nagle) Date: 2015-03-22 04:53
Installing Python 3.4.2 on CentOS 6.  Clean install.  Using procedure in README file:

./configure
make
make test

2 tests fail in "make test" The first one is because the FTP client
test is trying to test against a site that is long gone, the Digital Equipment Corporation Systems Research Center in Palo Alto:

ERROR: test_ftp (test.test_urllib2net.OtherNetworkTests) (url='ftp://gatekeeper.research.compaq.com/pub/DEC/SRC/research-reports/00README-Legal-Rules-Regs')
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/staging/local/python/Python-3.4.3/Lib/urllib/request.py", line 1399, in ftp_open
    fw = self.connect_ftp(user, passwd, host, port, dirs, req.timeout)
  File "/home/staging/local/python/Python-3.4.3/Lib/urllib/request.py", line 1445, in connect_ftp
    dirs, timeout)
  File "/home/staging/local/python/Python-3.4.3/Lib/urllib/request.py", line 2243, in __init__
    self.init()
  File "/home/staging/local/python/Python-3.4.3/Lib/urllib/request.py", line 2249, in init
    self.ftp.connect(self.host, self.port, self.timeout)
  File "/home/staging/local/python/Python-3.4.3/Lib/ftplib.py", line 153, in connect
    source_address=self.source_address)
  File "/home/staging/local/python/Python-3.4.3/Lib/socket.py", line 512, in create_connection
    raise err
  File "/home/staging/local/python/Python-3.4.3/Lib/socket.py", line 503, in create_connection
    sock.connect(sa)
TimeoutError: [Errno 110] Connection timed out


The second one is failing because "readline" (probably GNU readline) didn't behave as expected. The installed GCC is
"gcc (GCC) 4.4.6 20110731 (Red Hat 4.4.6-3)", which came with
"CentOS release 6.2 (Final)".  This is a long-running production server.
Is that too old?


FAIL: test_init (test.test_readline.TestReadline)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/staging/local/python/Python-3.4.3/Lib/test/test_readline.py", line 57, in test_init
    self.assertEqual(stdout, b'')
AssertionError: b'\x1b[?1034h' != b''
msg238872 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2015-03-22 05:13
The first test passes for me (although granted we should move that test to a psf hosted target, but we're slowly working on that general issue). The second is a bug in readline (see issue 19884).
msg238873 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2015-03-22 05:18
The test_ftp connection timeout error failure (seen on some platforms) is a duplicate of Issue22289.

The test_readline failure is a duplicate of, among others, Issue22647 and is believed to no longer occur with the current Python 3.4.3 (released 2015-02-25) and a GNU readline >= 6.3.
History
Date User Action Args
2015-03-22 05:18:07ned.deilysetnosy: + ned.deily
messages: + msg238873
2015-03-22 05:13:48r.david.murraysetstatus: open -> closed

superseder: Importing readline produces erroneous output
nosy: + r.david.murray

messages: + msg238872
type: behavior
resolution: duplicate
stage: resolved
2015-03-22 04:53:51naglecreate