classification
Title: Stack Trace should show argument value passed into a function, not just the keyword
Type: enhancement Stage: resolved
Components: Versions: Python 3.5
process
Status: closed Resolution: duplicate
Dependencies: Superseder: traceback module has no way to show locals
View: 22936
Assigned To: Nosy List: Umank Behera, r.david.murray
Priority: normal Keywords:

Created on 2015-03-20 18:50 by Umank Behera, last changed 2015-03-21 04:16 by r.david.murray. This issue is now closed.

Files
File name Uploaded Description Edit
st.py Umank Behera, 2015-03-20 18:50 source file
Messages (2)
msg238711 - (view) Author: Umank Behera (Umank Behera) Date: 2015-03-20 18:50
Code:
def main(foo):
    raise Exception("Some Exception")

bar = 1
main(bar)
----

On execution:
Traceback (most recent call last):
  File "st.py", line 5, in <module>
    main(bar)
  File "st.py", line 2, in main
    raise Exception("Some Exception")
Exception: Some Exception
----

It should show the value of bar is 1 on the first frame printed.
msg238758 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2015-03-21 04:16
Duplicate of issue 22936.
History
Date User Action Args
2015-03-21 04:16:33r.david.murraysetstatus: open -> closed

superseder: traceback module has no way to show locals
versions: - Python 2.7, Python 3.4, Python 3.6
nosy: + r.david.murray

messages: + msg238758
resolution: duplicate
stage: resolved
2015-03-20 18:50:08Umank Beheracreate