classification
Title: MacOSX Python child process running urlopen crashed when tkMessageBox is imported
Type: crash Stage: resolved
Components: Tkinter Versions: Python 2.7
process
Status: closed Resolution: duplicate
Dependencies: Superseder: urllib2 unrelease KQUEUE on Mac OSX 10.9+
View: 20585
Assigned To: Nosy List: ned.deily, r.david.murray, vinod sharma
Priority: normal Keywords:

Created on 2015-02-27 00:42 by vinod sharma, last changed 2015-02-27 08:48 by ned.deily. This issue is now closed.

Files
File name Uploaded Description Edit
crashreproduce.py vinod sharma, 2015-02-27 00:42
Messages (3)
msg236721 - (view) Author: vinod sharma (vinod sharma) Date: 2015-02-27 00:42
I've have an application which uses tkMessageBox module, multiprocessing module and urllib2 module. For some unknown reason, python child process is crashing silently while fetching a url. This only happens when tkMessageBox module is imported.
Sample code to reproduce the problem is attached. My operating system is MacOS 10.10
msg236726 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2015-02-27 02:23
When you say 'crash silently', what exactly do you mean?  How are you running the program?
msg236732 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2015-02-27 08:48
I was able to reproduce this and from the system crash report it appears that this is a duplicate of Issue20585.  The workaround noted there should work for you here: define a "no_proxy" environment variable to prevent Python from attempting to call the System Configuration framework for default proxy settings.  For example, if you don't need a network proxy, you could do:

no_proxy='*' python2.7 crashreproduce.py
History
Date User Action Args
2015-02-27 08:48:06ned.deilysetstatus: open -> closed

superseder: urllib2 unrelease KQUEUE on Mac OSX 10.9+

nosy: + ned.deily
messages: + msg236732
resolution: duplicate
stage: resolved
2015-02-27 02:23:26r.david.murraysetnosy: + r.david.murray
messages: + msg236726
2015-02-27 00:42:04vinod sharmacreate