classification
Title: SSL operations cause entire process to hang
Type: behavior Stage:
Components: Library (Lib) Versions: Python 2.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: alex, christian.heimes, dstufft, giampaolo.rodola, janssen, johnkw, pitrou
Priority: normal Keywords:

Created on 2015-02-26 19:58 by johnkw, last changed 2016-09-08 23:01 by christian.heimes. This issue is now closed.

Files
File name Uploaded Description Edit
sslbug.py johnkw, 2015-02-26 19:58 test case
sslbug.py johnkw, 2015-03-01 21:15 test case without "requests", and looping on both schemes
Messages (7)
msg236701 - (view) Author: johnkw (johnkw) Date: 2015-02-26 19:58
SSL operations cause entire process to hang.  At a minimum this includes the SSL read that goes on after a socket is connected.  It may apply to many other (or all) SSL socket operations.
msg236719 - (view) Author: Antoine Pitrou (pitrou) * (Python committer) Date: 2015-02-27 00:26
Can you post a standalone example that doesn't use requests and that doesn't rely on a local HTTP server?
msg236791 - (view) Author: johnkw (johnkw) Date: 2015-02-27 17:07
Not sure what you mean. That is a standalone example. It creates the local "HTTP server", which is merely a dummy listen socket. The whole point is just to have something that does a slow I/O operation, and simply not responding is sufficient for that to reproduce the bug.

Also, I would add that on further investigation this occurs on cygwin, but not on Linux.
msg236793 - (view) Author: Antoine Pitrou (pitrou) * (Python committer) Date: 2015-02-27 17:09
> It creates the local "HTTP server", which is merely a dummy listen socket

Sorry, I hadn't noticed. Still, the example shouldn't rely on the third party "requests" library.

> Also, I would add that on further investigation this occurs on cygwin, but not on Linux.

Cygwin is not a supported platform at all. Can you reproduce with an official Windows build?
msg236980 - (view) Author: johnkw (johnkw) Date: 2015-03-01 21:16
New testcase submitted without "requests". Don't have access to the non-cygwin build so don't know there.
msg245607 - (view) Author: johnkw (johnkw) Date: 2015-06-21 18:13
This bug is not present on Python 2.7.10 on 64-bit Linux.
msg275204 - (view) Author: Christian Heimes (christian.heimes) * (Python committer) Date: 2016-09-08 23:01
cygwin is not supported. Your demo script works on Linux.
History
Date User Action Args
2016-09-08 23:01:57christian.heimessetstatus: open -> closed
resolution: not a bug
messages: + msg275204
2015-06-21 18:13:16johnkwsetmessages: + msg245607
2015-03-01 21:16:06johnkwsetmessages: + msg236980
2015-03-01 21:15:14johnkwsetfiles: + sslbug.py
2015-02-27 17:09:19pitrousetmessages: + msg236793
2015-02-27 17:07:17johnkwsetmessages: + msg236791
2015-02-27 00:26:03pitrousetmessages: + msg236719
2015-02-26 20:25:43SilentGhostsetnosy: + janssen, pitrou, giampaolo.rodola, christian.heimes, alex, dstufft
2015-02-26 19:58:35johnkwcreate