classification
Title: make profile-opt: test_distutils failure
Type: behavior Stage:
Components: Versions:
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: gregory.p.smith Nosy List: gregory.p.smith, python-dev, skrah
Priority: normal Keywords: patch

Created on 2015-02-03 23:44 by skrah, last changed 2015-02-04 10:31 by gregory.p.smith. This issue is now closed.

Files
File name Uploaded Description Edit
issue23390.diff skrah, 2015-02-03 23:48 review
Messages (3)
msg235367 - (view) Author: Stefan Krah (skrah) * (Python committer) Date: 2015-02-03 23:48
Currently -fprofile-use etc. appear in the distutils CFLAGS, which
causes test_distutils to fail.
msg235370 - (view) Author: Gregory P. Smith (gregory.p.smith) * (Python committer) Date: 2015-02-04 04:19
Likely a dupe of http://bugs.python.org/issue22904 which is why i set the buildbot up. :)

I like your patch here better than my non-fixing poor hack in the other issue.  I hadn't noticed CFLAGS_NODIST before.
msg235383 - (view) Author: Roundup Robot (python-dev) (Python triager) Date: 2015-02-04 10:20
New changeset 8957ff9776bd by Gregory P. Smith in branch '3.4':
Fixes issue23390: make profile-opt causes -fprofile-generate and related flags
https://hg.python.org/cpython/rev/8957ff9776bd

New changeset 9c46707e5526 by Gregory P. Smith in branch 'default':
Fixes issue23390: make profile-opt causes -fprofile-generate and related flags
https://hg.python.org/cpython/rev/9c46707e5526
History
Date User Action Args
2015-02-04 10:31:08gregory.p.smithsetstatus: open -> closed
resolution: fixed
2015-02-04 10:20:26python-devsetnosy: + python-dev
messages: + msg235383
2015-02-04 09:49:49gregory.p.smithsetassignee: gregory.p.smith
2015-02-04 04:20:25gregory.p.smithlinkissue22904 superseder
2015-02-04 04:19:54gregory.p.smithsetmessages: + msg235370
2015-02-03 23:48:51skrahsetfiles: + issue23390.diff

nosy: + gregory.p.smith
messages: + msg235367

keywords: + patch
2015-02-03 23:44:57skrahcreate