classification
Title: operator precedence table for `not x` has an operand, while the others do not
Type: enhancement Stage: resolved
Components: Documentation Versions: Python 3.2, Python 3.3, Python 3.4, Python 3.5, Python 2.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: docs@python Nosy List: Hobson.Lane, docs@python
Priority: normal Keywords:

Created on 2015-01-28 22:20 by Hobson.Lane, last changed 2015-01-28 22:44 by r.david.murray. This issue is now closed.

Messages (2)
msg234919 - (view) Author: Hobs (Hobson.Lane) Date: 2015-01-28 22:20
Shouldn't the [operator precedence table](https://docs.python.org/3.4/reference/expressions.html#operator-precedence), 5th row, 1st column, just say "`not`" rather than "`not` x"? The other rows are identified by the keyword for the operator and don't include any operand(s). Is there some other expression that includes `not` that should have a different position in the precedence table?
msg234921 - (view) Author: Hobs (Hobson.Lane) Date: 2015-01-28 22:23
Just noticed the other entries for not. Not a bug.
History
Date User Action Args
2015-01-28 22:44:01r.david.murraysetstage: resolved
2015-01-28 22:23:35Hobson.Lanesetstatus: open -> closed
resolution: not a bug
messages: + msg234921
2015-01-28 22:20:44Hobson.Lanecreate