classification
Title: [IDLE/Windows] Run python with restricted rights
Type: behavior Stage: resolved
Components: IDLE, Windows Versions: Python 3.5, Python 3.4
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: Ramchandra Apte, marcd, steve.dower, terry.reedy, tim.golden, zach.ware
Priority: normal Keywords:

Created on 2015-01-28 10:24 by marcd, last changed 2017-06-23 06:50 by terry.reedy. This issue is now closed.

Files
File name Uploaded Description Edit
python_error.png marcd, 2015-01-28 10:24
Messages (5)
msg234883 - (view) Author: Marc (marcd) Date: 2015-01-28 10:24
Hi,

We work in a school within a domain and pupils are using different restricted account on this domain. We tried to install Python 3.4 and it's work with an Administrator Account.


With Children account , we got the message "IDLE's subprocess didn't make connection. Either IDLE can't start a subprocess or personal firewall software is blocking the connection"  .


We checked if there is any python file in the  python.exe directory like advised on http://stackoverflow.com/questions/874757/python-idle-subprocess-error.

We also tried to give more right on the python directory for the children account.

If anyone have a solution please let me know.

Thanks
msg234890 - (view) Author: Ramchandra Apte (Ramchandra Apte) * Date: 2015-01-28 12:58
BTW I think this is more of a support request than an issue.

I might be stating the obvious, but is there any firewall software installed?
msg234958 - (view) Author: Marc (marcd) Date: 2015-01-29 09:42
Hi Ramchandra,

I actually have an AV (Sophos) but no firewall on the computer
msg235087 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2015-01-31 07:52
I agree that this would have been better asked on python-list.  However... I would like a better handle on when this occurs to either make it happens less or better document workarounds.  How did you install python?  The .msi installer from python.org?  Which directory? 34 or 64 bit? Which Windows version? Install for all users or just one account?  How start Idle?

In the meanwhile, at a Command Prompt command line,
> python -m idlelib -n 
should work.
msg296682 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2017-06-23 06:50
There is insufficient information to establish that this is a bug in IDLE, hence it is not possible to write a patch.
History
Date User Action Args
2017-06-23 06:50:07terry.reedysetstatus: open -> closed
resolution: not a bug
messages: + msg296682

stage: test needed -> resolved
2015-02-02 14:30:42vstinnersettitle: Run python with restricted rights -> [IDLE/Windows] Run python with restricted rights
2015-01-31 07:52:45terry.reedysettype: crash -> behavior
components: + IDLE
versions: + Python 3.5
nosy: + terry.reedy

messages: + msg235087
stage: test needed
2015-01-29 09:42:30marcdsetmessages: + msg234958
2015-01-28 12:58:03Ramchandra Aptesetnosy: + Ramchandra Apte
messages: + msg234890
2015-01-28 10:24:42marcdcreate