classification
Title: python hangs on call to numpy.outer
Type: crash Stage: resolved
Components: Versions: Python 2.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: jwbwater
Priority: normal Keywords:

Created on 2015-01-24 06:37 by jwbwater, last changed 2015-01-24 12:54 by mark.dickinson. This issue is now closed.

Files
File name Uploaded Description Edit
dome_projection.py jwbwater, 2015-01-24 06:37
Messages (2)
msg234593 - (view) Author: Jim Bridgewater (jwbwater) Date: 2015-01-24 06:37
python hangs when this script is run and if it is allowed to continue running OS X produces system out of memory errors
msg234594 - (view) Author: Jim Bridgewater (jwbwater) Date: 2015-01-24 07:06
Turns out an outer product of two million element vectors takes up a lot of memory.  Go figure.
History
Date User Action Args
2015-01-24 12:54:56mark.dickinsonsetstatus: open -> closed
stage: resolved
2015-01-24 07:06:26jwbwatersetresolution: not a bug
messages: + msg234594
2015-01-24 06:37:50jwbwatercreate