classification
Title: ImportError: No module named _bsddb
Type: Stage:
Components: Library (Lib) Versions: Python 2.4
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: ddk, gregory.p.smith, trent
Priority: low Keywords:

Created on 2008-03-17 17:25 by ddk, last changed 2008-03-20 15:32 by gregory.p.smith. This issue is now closed.

Messages (3)
msg63682 - (view) Author: dd (ddk) Date: 2008-03-17 17:25
Installation from source, python.2.4.5.tgz.
It seems that severals *.so from bsddb are missing:
>>> import bsddb
Traceback (most recent call last):
  File "<stdin>", line 1, in ?
  File "/tmp/Python-2.4.5/Lib/bsddb/__init__.py", line 47, in ?
import _bsddb
ImportError: No module named _bsddb
msg64133 - (view) Author: Trent Nelson (trent) * (Python committer) Date: 2008-03-20 00:30
Please provide more information about your platform.  Also note 
that ./configure needs to be able to find pre-existing bsddb libs in 
order for Python to build the _bsddb module.
msg64172 - (view) Author: Gregory P. Smith (gregory.p.smith) * (Python committer) Date: 2008-03-20 15:32
BerkeleyDB is detected when make runs setup.py.  Look in the output from
your make and you'll see a message about whether or not a useful
BerkeleyDB library and include files were found.

Typically this happens on linux distros because people do not have a
bsddb-dev type package installed containing the header files needed to
compile.
History
Date User Action Args
2008-03-20 15:32:33gregory.p.smithsetstatus: open -> closed
priority: low
resolution: not a bug
messages: + msg64172
nosy: + gregory.p.smith
2008-03-20 00:30:16trentsetnosy: + trent
messages: + msg64133
2008-03-17 17:25:41ddkcreate